Displacement texture PBR not working in planes

Some how the PBR displacement map is working on the sphere but not on a plane.

If you displace a simple plane and nothing appears to be happening your render mesh on the plane is not dense enough. It probably has only 4 vertices.

  1. select plane
  2. open object properties panel
  3. check Custom mesh
  4. open custom mesh settings
  5. tweak settings to get a dense mesh. Set density to 1.0, edge length to something that is 1/10th of the shortest edge of your plane, aspect ratio to 1.0

Thanks. That worked. Isn’t there a way of doing that automatically. I had done this with other engine and I don’t remember having to adjust the mesh (but it was long ago).

A more generic question. In terms of rendering and materials, was there any other development apart from adding PBR materials? and within that is there a way of having displacement texture in “normal” materials?
Thanks, N

PBR is probably the most visible addition. Displacement textures like that are available only in PBR materials. There is of course the Displacement mesh modifier, but that is more of a pre-process thing than material.

A new premade simplification of PBR is the emission material. Using that you can make emissive objects.

Three different denoiser plug-ins are now available through the _PackageManager (AMD, Intel, Nvidia).

The upcoming WIP release should have a separate Alpha transparency channel and ability to use basecolor texture alpha as that as well.

Under the hood Rhino Render is now the same as the Raytraced viewport mode.

A post was split to a new topic: Custom mesh setting on Command line?