Disable Right Button Rotate

I think there must be a simple answer to this one but I can’t find it - is it possible to disable the right mouse button view rotation? I use a 3D Connexion device so don’t need to use the mouse for view manipulation. Occasionally when pressing the right button to accept/enter, I rotate the view a little instead (I must move the mouse slightly). It would be nice if I could prevent this from happening. Can it be done?

Hi MisterB - as far as I know there is no way to do this now, no.

-Pascal

Thanks for your reply, Pascal. At least I haven’t got egg on my face for overlooking an obvious solution :slight_smile:.

I don’t know if other 3D Connexion user’s notice this minor annoyance, perhaps it’s just me. It would be nice if it could be disabled in v6 but it’s no big deal.

Thanks again for your help.

Hi Mr.B - I don’t know if it is more of a problem for 3dConnexion users, do you think? I’d expect it to turn up in general, it’s just that 3dconnexion users have another way to noodle the view so are OK with disabling the default behavior… am I looking at that right or missing something?

I have had coffee this morning.

https://mcneel.myjetbrains.com/youtrack/issue/RH-38425
-Pascal

Hi Pascal, I think you’re absolutely right - this minor annoyance wouldn’t be limited to 3D Connexion users. We all use the right click to accept/enter and, if like me, you move your mouse a tad as you click the view rotates instead (limited to the perspective view). Maybe my mouse is too sensitive (Logitech MX Master), but my old one did the same.

On average I probably only do this a couple of times a day so it isn’t a big issue, but it would be nice if you could disable it so right click didn’t rotate. As you say, 3D Connexion users don’t need that functionality.

Did this suggestion ever go anywhere? It’s an issue I still encounter almost every day - perhaps I’m the only user that has a problem with moving my mouse when I right click. Be nice to have a box to disable it though.

Sorry to bump an old thread.

I’m using 3D Connexion products for ages and I would not deactivate the native Rhino rotate view behaviour. I like to have options, depending on what I do.

I do have some clicking issues too but those tend to be caused by the mouse getting old and the buttons not reacting as they did when the mouse was new.

I bought a brand new mouse (latest MX Master) only weeks ago so I don’t think I can blame the tool on this occasion.

Agreed, its good to have options. I’d like the option to turn off rotation with the right mouse button. It seems like a simple solution to alleviate a minor annoyance.

But I acknowledge this isn’t a common problem, in four years this thread hasn’t seen much action so perhaps I’m the only one.

I too am encountering this problem. View pans in orthogonal views and rotates in perspective view with the slightest moment of the mouse when pressing the right mouse button for Enter. It is quite annoying. Even though there are other ways to enter Enter, I’ve just grown so accustomed to using the right mouse button, I’m finding it very difficult to find a comfortable alternative. I use 3D Connexions’s Space Navigator, so I too would like the option to disable this functionality of the right mouse button, if not some control over the sensitivity to mouse movement. I see an option has been added to adjust the context menu delay for the right mouse button, perhaps this could be done for the pan / rotate as well? Any update on this issue? Thank you.

Hi James, all - Added to the pile - I do not know what is possible

RH-67445 RMB roatation: allow delay

-Pascal

Pascal, Thank you for your prompt reply. I should have noted that I am using a 3DConnexion CadMouse Pro mouse.