Dimensions in layout space ignore model space scale now?

Dimensions in layout space are no longer affected by model space scale (as opposed to R5)?


I believe these settings are involved too:

They (those checkboxes) do nothing for the dimensions placed in layout space. Neither of them.

Model space scaling works for dims in the model space or visible in detail views.
Layout space scaling does nothing here.

Hello - layout scaling allows model space dims to be of a constant as viewed from a layout.


My dims are not in the model space viewed through the detail. They are in the layout space.

Hi - could you post a file with those annotation styles (if you could limit that to the two that you used, that would be great) so that we can take a closer look at the settings?

Here you go. R6 now keeps the settings in the model file?
layout dims broken scale.3dm (5.2 MB)

Hello - layout scaling is for the display of model space dims in details - if enabled, these are constant and independent of zoom.

" Enable layout space scaling

When checked, annotation text and arrows in detail views will display with a static size in Layouts regardless of the zooming ration of the detail views."


Are you saying that layout space in R6 is supposed to ignore “model space scale” anno number? 'cause it didn’t in R5. Not a big deal to us to be frank, just trying to understand the reasoning behind change.
Was/is R5 bugged all that time if it’s an intended behavior?

Oh, yeah, sorry, I was barking up the wrong tree there - yes model space scaling applies to model space dims as viewed in model space - I’ll ask @mary but I think that was a user request(?) So dims should be sized to look right in layouts and then scaled, if needed, in model space, is the idea.


@pascal is correct.
Rhino 5 would scale a dimension on the layout dimension by the model scale.
That did not make sense to most users and behavior was changed in Rhino 6.

So in Rhino 6, a dimension that is created on the layout is not scaled by the Model scale value of the dimension style.

When Layout scale is not enabled, the dimension is displayed in the detail at the model scale.

In Rhino 6, the result is that the layout dimension is not affected by the model scale value:

When Layout scale is enable, in Options -> Annotation…

…text and dimensions are displayed true size , no model scale is applied.

Hope that helps.
Mary Ann Fugier

I’m trying to set up a template sheet where I can easily do my 2D drafting AND dimensionsing within model space. I’ve followed your steps and in paperspace, the dimensions appear to be the correct size. However, in model space, if Im working on a drawing, the text is too small and I can’t see it. So must I create a unique annotation style for each scale of drawing I’m working on within modelspace? Or can I rely on one style as I had in the past when dimensioning from layout view (paperspace)? Thank you.

Hi Peter,
If you want one annotation style that will work for all Details with different scales, you will need to turn annotation scale on.

If you switch to a model viewport like top, front, right - then the Model scale of the Annotation style is used, if this is checked:

Please upload your template 3dm for me to look at.
Mary Ann Fugier

Check this out. Basically Model space scaling is fairly useless to us or any other architectural drafting workflow, just because model space scaling doesn’t scale the dim text offset. If it did, we wouldn’t have to have this:

We’d have exactly One architectural style and One fractional instead of the whole scale list. Just because dim text offset is different from scale to scale.

See here:

test dimensions.3dm (73.5 KB)
Thank you Mary. I found out that I had to change my “model space scale” within the annotation style in order to make the text big enough to see within model space.

So a question… if Im working on a plan where I will have both overall view (say 1/16" scale) and detailed view (say 1" scale), I would have two layers of dimensions in this case? One for the 1/16 and one for the 1"? ANd then just turn off the layer for the corresponding viewport. How would you go about that situation? Is there a different way?


It seems PeterB that you are not using Layouts and details to make your plans, but only doing your drafting in model space?

I draft a ton of plans and all my dimensioning is in layouts.

Having dimensions in layouts can suck if you have to go back to revise your model. You’d have to literally re-pull all the dims manually. While in the model you can speed up the process using scripts.

Hi Peter,
I will assume that you are on a layout and you have two details. One has a scale of 1/16 and there full size 1. If layout scale is enabled, then the same dimensions will display correctly in both details, since the arrows, text height, spacings are displayed full size in each detail. i.e. Text that is .25 units high displays .25 units in both details.

If you do not want the dimension from the first detail visible in the second detail, you have two options for controlling visibility: one by layer and the other by object.

Like you described, you can have layers that are “off in detail” in one , and leave visible in the other detail. If you turn the layer off off globally, it is off everywhere in the model.

By object visibility is available with the commands HideInDetail, ShowInDetail, and ShowSelectedInDetail. In this case you would pick HideInDetail, select the dimensions you do not want to see, and Enter to hide. If you need them back, use one of the commands ShowInDetail and ShowSelectedInDetail.

Hope this helps.
I am happy to work you up an example file if you would like it.
Mary Ann Fugier

I don’t understand your point. Please explain.

How do you use scripts to speed up your drafting?