Different results on different computers

Hi everyone !
I have a problem with Grasshopper. Two weeks ago I had an assignment for a course, I had to modelize a Candela’s building only with Grasshopper, and by making a hyperbolic paraboloid. Today we received our grades and mine weren’t very good, so I sent an email to the teacher and after discussion, I realised that we see completely different things on our computers. In my file, there is nothing in orange and a shape appears and in hers, there are different things in orange and there is no shape. !
Could you help me find a solution ? I’m lost and I don’t know what could be the problem… I didn’t use rhino at all to modelize the building.
Please don’t judge the file, I know it isn’t optimized but we didn’t see list and tree yet.
Thank you
Paraboloide hyperbolico.gh (43.7 KB)


Somethings to consider:
Having different Rhino versions
Having different tolerances
Using any kind of random function
Missing geometry references
Using different plugins

I presume you are a student.
Could it be that your are not using the interface?
for example, look for the documentation manual for this UI buttons

You can see in the screenshot. What he is saying is when his prof opens it that some components throw warnings and don’t work.

1 Like

I sent my file to one of my friend and he could see everything right.
I really don’t understand what’s wrong.
We are suposed to have the same rhino versions, I didn’t change tolerances before (I tried to change it today to see if there was any differences but there isn’t), there is no random function in this file, I only use grasshopper to create the shapes and I used basic command for all the file.
If one of you open the file, do you see any problem ?

Thank you for the help ! :slight_smile:

Hi - this looks fine here - in a Rhino 7 document in meters and tolerance set to 0.001:


Thank you ! I still don’t know why it doesn’t work for my teacher but I’m relieved that it works on other computers

Everything shows up fine in your file for me. I’m using Rhino V6 to open your file.

Maybe your teacher is using Rhino V5? R6 and R5 are not a 100% compatible, as components can provide outputs in different order sometimes messing up things like for example List Item later down the line.

If you are both using the same Major version of Rhino that would be quite interesting.

If you could post a screenshot of what your teacher sees, that would be helpful.

Also, have you considered that your teacher could be mistakenly looking at a different file?

Worked fine for me as well.