Did I break my Text Tag 3D component? Is it a bug?

Hi there,

I am currently working on a huge script, but one tiny little detail drives me crazy.
Since the algorithm I am making is intended to operate on shapediver, I needed a solution to display text in the viewport. And everything worked fine with the simplified definition you can see attached, until I wanted more.
I wanted to use different font types and tried to install the FabTools component from food4rhino. I knew it is not compatible with my current RH6 Version, but I thought I’ll give it a shot. The component did not work very well, so I removed it from my component folder soon and since then I get a weird little bug, which drives me crazy.

Whenever I try to join some strings with a paragraph inbetween, the viewport first shows the two strings above each other correctly. But as soon as I click anything or move the perspective it decides to show them attached in one line instead.

200507_text_example.gh (7.1 KB)

I really tried many things before writing this down here. I even already uninstalled Rhino, cleaned all the appdata folders, etc, reinstalled it, nothing changed. I can not imagine how the Tool now behaves so different. On my other computer this definition is working fine.

I would be very glad if someone knows how to fix this.

Best regards,


Hi and welcome to the forum.

Did you try rhino in safe mode and/or launch grasshopper with “GrasshopperLoadOneByOne” command and using gh vanilla? (to avoid any gh plugin, to test Text Tag alone)

Also, why don’t you update your Rhino installation?

Hi Riccardo,

thanks for your quick reply! :slight_smile:

Unfortunately safe mode without loading gh plugins did not help. I tried updating my Rhino installation before, but since nothing changed I decided to completely reinstall it. But that didn’t help either. I am wondering if it’s a Windows-related problem by now…

The file attached should illustrate the problem a bit better. This time I also used the definition to feed the 2d text tag and it works…

But as soon as I do anything, the two strings in the text tag 3d component magically stick to each other. So strange.

What is in the text panel connected to the ‘J’ input? I used a single <ENTER> (Carriage Return) and it works for me.

text_2020May07a.gh (5.7 KB)

P.S. Works fine with Merge too.

text_2020May07b.gh (6.5 KB)

What do you mean by “do anything”?

1 Like

Hi Joseph,

thank you for your reply. By “do anything” I literally mean anything, like navigating through the canvas, clicking on components, scrolling in the viewport, any action triggers the component to display the input wrong.

I’ll test your file in a few minutes, but I believe I can promise you, that it will be displayed exactly the same as mine. I also used a single <ENTER> (Carriage Return) .

Thank you for your efforts!

Hi Joseph,

this is your definition opened on this strange behaving computer.
As I promised: It doesn’t do what it should do…

And did you check the content of the panel with the <ENTER> (<CR>)?

Why haven’t you posted code of your own? I REALLY hate to ask for it… :man_facepalming:

Mac or Windows? R5 or R6? I’m guessing the ‘J’ input panels are being emptied or ignored.

I am sorry. I am new to this kind of problem solving. It’s a pretty new Notebook with Windows 10, with onboad graphics Intel 620, Rhino Version is 6 SR25 (6.25.20114.5271, 23.04.2020). Even freshly and with no plugins installed, it behaves like this.

Here is my file:
200507_text_example.gh (7.1 KB)

What if you bake the text?

Then it’s displayed correctly! :slight_smile:
But for formatting it’s not a nice workflow to always bake stuff to see the changes.

Your file works for me. Wish you had included it with your first post…

Yeah, but it means the actual string/data is correct, as when passed to rhino it contains the “Enter” character.

Maybe it is a openGL problem? My knowledge here is very little…
… trying to reinstall GPU drivers?

Have you tried different view settings in rhino? like disabling gpu tessellation…
I don’t know, sorry…

@stevebaer can i “summon” you? :sweat_smile:
Can you give us an opinion? (I don’t know if this is a matter of yours)

1 Like

What happens if you connect a text panel to the Join output?



hmm, the panel looks like yours.

This doesn’t looks like a display bug on the GPU driver and OpenGL side. Individual characters are drawn one at a time and offsets for those characters are computed so we know where to place them. This looks like something in our character placement code is not seeing a “newline” in your string. If you have a repeatable sample, we should be able to find and fix the bug.

1 Like

He provided one but it’s only repeatable on his machine, works fine on mine.

Thanks @Joseph_Oster, I missed that.

@sebastianschanz please run the SystemInfo command in Rhino and paste the results here. I’m interested to know if there are any 3rd party plug-ins installed on your system.

Thanks @stevebaer for your attention to this topic.
This is my systeminfo:

Rhino 6 SR25 2020-4-23 (Rhino 6, 6.25.20114.05271, Git hash:master @ f35d7ded15ec317635ced435d8df84327397038d)
License type: Educational, build 2020-04-23
License details: Cloud Zoo. In use by: Sebastian Schanz ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-SD0V3CK

Non-hybrid graphics.
Primary display and OpenGL: Intel® UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 9-25-2019 (M-D-Y). OpenGL Ver: 4.6.0 - Build

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build
Driver Date: 9-25-2019
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.25.20114.5271
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

The systeminfo didn’t show anything out of the ordinary. What does your component folder contain?

This is my grasshopper component folder. Additionally there is pufferfish in my libraries folder. I will attach another screen immediately.

and the libraries folder: