Denoiser issue

Jorgen

I believe that part of the bug has been fixed.
_ Andy

1 Like

Regarding RH-60016 the problem is that the CPU utilization doesn’t match the gained benefit, most of the CPU cycles are actually lost to overhead (thread managementy stuff) instead of doing anything useful (copying pixel data). This is when Raytraced is otherwise rendering on the GPU.

I guess that part should be split off from this thread.

3 Likes

Yup - that part I understand…but let’s say I make things go 100% faster, but instead of using 20% of CPU, I’m using 100%…will people be happy or sad?

I don’t see faster rendering in V7…

Using the whole CPU is not good, as we can’t do anything useful on the PC when a single Rhino instance eats all the power.
We select CUDA, and not CPU for reasons.

This will be fixed in the next WIP

1 Like

RH-60016 is fixed in the latest WIP

1 Like

This seems too work well now, both for the intel and the nVidia denoiser. The CPU load drops down to 0% once raytraced view is toggled off OR paused. That seems better than ever before, even without raytraced being used at all.

I do see that when using the intel denoiser the CPU is constantly used at around 50% (Dual six core xeon). Does that mean that it runs constantly at full trottle and outputs the denoised results as fast as they are done? It takes around five seconds between each denoised frame update in fullHD when the intel denoiser is activated.

Yes. That’s how it works.

1 Like

All fixed in (7.0.20238.17095, 25.08.2020).
Great!

I see the CPU is still being used even when the viewport is done calculating. Intel Denoiser is turned ON:

@Holo, do you see this CPU usage also when the denoiser is off? What Rhino BETA version are you using? (First line of _SystemInfo).

Same in here: 7.0.20273.15003

I believe this is already fixed. The fix will be available in the next BETA release.

7.0.20280.* or newer should have it in.

It is fixed, but now there is another problem:

Let Cycles finish.
Now check Intel Denoiser and wait for finished.
Uncheck Intel Denoiser.
Original image is seen in the viewport.
Now check Intel Denoiser again.
Works.
Uncheck Intel Denoiser.
Check AMD or NVidia Denoiser.
Strange result with AMD.
No result with NVidia.

Nathan, you have a pretty similar hardware like me, so you should see this as well.
Or?

EDIT:
I tried to record a video.
Once I checked Intel Denoiser Rhino died and vanished.

@Charles the denoisers are done by @DavidEranen. They are completely separate from Cycles.

Ah ok, but the result is the same for me :slight_smile:
In any case, something is wrong.
Thanks Nathan.

@Charles understood. But that is why I @-mentioned @DavidEranen so he gets notified.

There is a bug report about crashing when repeatedly toggling intel denoiser. I believe @DavidEranen is close to releasing new denoiser plug-ins to fix the crashing bug.

Hi @Charles,

There should be a new version of the Intel Denoiser available now (v0.6.0). Please download the latest BETA before updating.

-David

Done:

On the first start after _PacketManager, only AMD Denoiser was there.
Shutdown - restart
Intel is there.
But doesn’t work at all (screenshot after 20 sec waiting):
image


AMD doesn’t work either (this is an AMD PC):


And NVidia isn’t there…
Shutdown - restart
Aha, NVidia is there.
I think this is an issue with the package manager.
OK, but NVidia doesn’t work:
image


Can you retrace that?
BETA
(7.0.20280.13133, 06.10.2020)

I believe the package manager only activates one plug-in each Rhino start, even if you installed many in one go. @will is the person who knows best.

Personally I think it should not be necessary to even restart Rhino in most cases…