AMD denoiser not working

AMD denoiser doesn’t work on my MacBook Pro 16" with AMD 5500m GPU.

I’m using v7 WIP and running Big Sur.

It comes up with this error.

Logged as RH-61648 AMD Denoiser not working on Mac.

@robinp if you could run the Rhino command _SystemInfo and paste the results here.

Rhino 7 SR0 2020-11-4 (Rhino 7 BETA, 7.0.20309.06004, Git hash:master @ 368ab021c8426434a95c36999f545f918e04df2c)
License type: Commercial, build 2020-11-04
License details: Cloud Zoo
Expires on: 2020-12-19

Apple Intel 64-bit macOS Version 10.16 (Build 20B29) (Physical RAM: 64Gb)
Mac Model Identifier: MacBookPro16,1
Language: en-GB (MacOS default)

AMD Radeon Pro 5500M OpenGL Engine (OpenGL ver:4.1 ATI-4.0.47)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: AMD Radeon Pro 5500M
Displays: Color LCD (264dpi 2x), DELL U2715H (109dpi 1x)

Graphics processors
Intel UHD Graphics 630 (1536 MB)
AMD Radeon Pro 5500M (4 GB)
Color LCD (1792 x 1120 @ 59Hz)
DELL U2715H (2560 x 1440 @ 59Hz)

USB devices
CalDigit: Card Reader
Seagate: Expansion
CalDigit, Inc.: CalDigit Thunderbolt 3 Audio
Realtek: USB 10/100/1000 LAN
Apple Inc.: iPhone
Apple: composite_device
Apple Inc.: Touch Bar Backlight
Apple Inc.: Touch Bar Display
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple: Headset
Apple Inc.: Ambient Light Sensor
Apple Inc.: FaceTime HD Camera (Built-in)
Apple Inc.: Apple T2 Controller

Bluetooth devices
Nordic Semiconductor:

Third party kernel extensions
None

Third party plugins
/usr/lib/swift/libswiftAppKit.dylib
/usr/lib/swift/libswiftCloudKit.dylib
/usr/lib/swift/libswiftContacts.dylib
/usr/lib/swift/libswiftCore.dylib
/usr/lib/swift/libswiftCoreData.dylib
/usr/lib/swift/libswiftCoreFoundation.dylib
/usr/lib/swift/libswiftCoreGraphics.dylib
/usr/lib/swift/libswiftCoreImage.dylib
/usr/lib/swift/libswiftCoreLocation.dylib
/usr/lib/swift/libswiftDarwin.dylib
/usr/lib/swift/libswiftDispatch.dylib
/usr/lib/swift/libswiftFoundation.dylib
/usr/lib/swift/libswiftIOKit.dylib
/usr/lib/swift/libswiftMetal.dylib
/usr/lib/swift/libswiftObjectiveC.dylib
/usr/lib/swift/libswiftQuartzCore.dylib
/usr/lib/swift/libswiftUniformTypeIdentifiers.dylib
/usr/lib/swift/libswiftXPC.dylib
/usr/lib/swift/libswiftos.dylib
/usr/lib/swift/libswiftsimd.dylib
/usr/lib/swift/libswiftAccelerate.dylib
/Users/robinphillips/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/bella_rhino.rhp/libbella_dotnet_native.dylib
/Users/robinphillips/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.0/libtbb.dylib
/Users/robinphillips/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.0/libtbbmalloc.dylib
/usr/lib/log/liblog_network.dylib
/Users/robinphillips/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.0/libOpenImageDenoise.1.2.3.dylib

Rhino plugins that do not ship with Rhino
/Users/robinphillips/Library/Application Support/McNeel/Rhinoceros/MacPlugIns/bella_rhino.rhp “Bella” 20.7.0.0
/Users/robinphillips/Library/Application Support/McNeel/Rhinoceros/packages/7.0/raytraced-materials/0.1.3+v6.15/RaytracedMaterials.rhp “Raytraced Materials” 0.1.3.0
/Users/robinphillips/Library/Application Support/McNeel/Rhinoceros/packages/7.0/raytraced-blend-material/1.3.0/RaytracedBlendMaterial.rhp “RaytracedBlendMaterial” 1.3.0.0
/Users/robinphillips/Library/Application Support/McNeel/Rhinoceros/packages/7.0/AMDDenoiser/0.4.1/AMDDenoiser.Mac.rhp “AMDDenoiser.Mac” 1.0.0.0
/Users/robinphillips/Library/Application Support/McNeel/Rhinoceros/packages/7.0/IntelDenoiser/0.6.0/IntelDenoiser.Mac.rhp “IntelDenoiser.Mac” 1.0.0.0

Rhino plugins that ship with Rhino
/Applications/RhinoWIP.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.0.20309.1002
/Applications/RhinoWIP.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.0.20309.1002
/Applications/RhinoWIP.app/Contents/PlugIns/AnimationTools.rhp “AnimationTools” 7.0.20309.1002
/Applications/RhinoWIP.app/Contents/PlugIns/SolidTools.rhp “SolidTools” 7.0.20309.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.0.20309.1002
/Applications/RhinoWIP.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.0.20309.1002
/Applications/RhinoWIP.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.0.20309.1002
/Applications/RhinoWIP.app/Contents/PlugIns/MeshTools.rhp “MeshTools” 7.0.20309.1002
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_OBJ.rhp “Import_OBJ” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_XAML.rhp “export_xaml” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/QuadRemesh.rhp “QuadRemesh” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_OBJ.rhp “export_OBJ” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_SVG.rhp “Export SVG” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_DAE.rhp “Export_DAE” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PDF.rhp “PDF Export” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_IGES.rhp “IGES Export Plug-in” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_SVG.rhp “Import_SVG” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_AMF.rhp “Export_AMF” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/import_DST.rhp “Import_DST” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PLY.rhp “PLY - Polygon File Format Export” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_AMF.rhp “Import_AMF” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.0.20309.6004
/Applications/RhinoWIP.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.0.20309.6004

Hi @robinp,

Just want you to know that we’re looking into this.

-David

1 Like

Hi David

I’m having a total crash with the Flamingo renderer when I try to engage the AMD Denoiser (clicking the selection box). My system is totally different from rbinp’s so there seems to be something seriously wrong under the hood:
Rhino 7 SR3 2021-2-22 (Rhino 7, 7.3.21053.23031, Git hash:master @ f8a40388712d9cf7edc68910e0415427bdefc64a)
License type: Kommerziell, Build 2021-02-22
License details: Cloud Zoo

Windows 10.0.18363 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: AMD Radeon ™ R9 200 Series (AMD) Memory: 2GB, Driver date: 11-13-2020 (M-D-Y). OpenGL Ver: 4.6.14757 Compatibility Profile Context 20.11.2 27.20.14501.18003
> Accelerated graphics device with 8 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.6
Shading Language: 4.60
Driver Date: 11-13-2020
Driver Version: 27.20.14501.18003
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\Flamingo nXt 5.0 (fd53f8c4-546d-47d1-8820-e66c97645a97)\5.5.18347.11581\5.5\Flamingo.nXt.rhp “Flamingo nXt 5.5” 5.5.18347.11581
C:\Users\Andreas\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\AMDDenoiser\0.4.1\AMDDenoiser.Windows.rhp “AMDDenoiser.Windows” 0.4.1.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.3.21053.23031
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Since there is no further reply to robin’s post it seems there is no answer yet. So I’ll add my bug to the list.

Andrew

Does it work better if you use the Intel denoiser instead?

Yes, that works.

Ok, I think your GPU is too old for the AMD denoiser to work properly. Maybe a driver update may help, but if the Intel denoiser works for you I’d stick to that.

Thanks for the tip.

As you indicated the graphics card is probably “too old” since I’m current on all my drivers on the stable releases. I doubt that AMD will or even can jack it up to the newer requirements of openCL and openGL.

Hi @andrew_klemm,

I would like to know if the AMD denoiser is still working badly for you. Could you get the latest Rhino 7 version + latest AMD denoiser and do another test?

Thanks,
-David

Hi David

Tried the scene again and the denoiser seems to work fine. I did change a few things: I’ve installed a new graphics card (AMD Radeon WX5100), cleaned the CPU cooler and have the most current version of Rhino.

Regards

Andrew

1 Like