"Del" by keyboard is gone?

Hi, I noticed in last wip release (6.0.16215.11561, 2/8/2016):
when having some object selected… “del” key isn’t working as usual…
If it is intended I’ll miss that functionality, it is very useful and a quick way of deletion, also inside multiple selection drop down list.

Are you running on a Bootcamp partition on a Mac?

No, plain rhino wip in Windows 10 Home 64

Then I think you’re having keyboard issues.

Thanks for your answers John…
More research on this:
same File opened in rhino 6wip and rhino5: "del"key works OK on rhino 5 and didnt work in rhino 6.!
after closing and restarting rhino 6 wip session solved this issue…
And yesterday I noticed this behaviour in another file with rhino 6 wip…
I will keep testing if this happens again as I cant determine the reason… (my systems seems to be working fine but who knows) I’ll report back here if I find more data on this.

There are other applications that can remap keyboard functions. PhotoShop is one that come to mind.
ANy chance you had other applications running when the Rhino Delete key quit?

Sorry …none that I can remember, but I will pay special attention on this next time it happens…

I know this post is old but another reason “del” can stop working has to do with a long-present bug in Grasshopper - Rhino will unexpectedly stop responding to “Del,” “tab,” “Enter,” and several other keys - and only restarting Rhino seems to fix the issue. It has never been clear to me what series of actions in Grasshopper cause this to occur - and I’ve tried hard to create a reproducible case, to no avail. It has plagued me on a number of machines, thru many different versions of GH + Rhino - although it only happens occasionally.

1 Like