Default Materials Library in Windows 10


#1

Last week I started using Rhino 5 on Windows 10 (have several years’ experience on older Windows versions), and can’t find the default materials library.

In Document Properties the default location is shown as C:\Users\jness\AppData\Roaming\McNeel\Rhinoceros\5.0\Localization\en-US\Render Content, but as I browse through my computer I’m not able to navigate to that location–I turned on “Hidden items” in the View menu to reveal the AppData folder, and was able to navigate as far as the “5.0” folder, but the Localization folder doesn’t exist.

If I copy/paste the above path in a Windows Explorer address bar, a “Windows can’t find…” dialog box opens, confirming that the default location Rhino is trying to use doesn’t exist.

Given all of that, I am assuming the default materials library wasn’t installed with the rest of the program. How can I install and access the default materials? I don’t need to generate photo-realistic renderings, so the defaults are a great starting point for basic screen shots.


(Pascal Golay) #2

Hi Joel - it’s possible that running ToolbarReset and restarting Rhino will sort this out - give that a try.

-Pascal


#3

Thanks Pascal. Tried it and unfortunately it didn’t change the fact that the Localization folder is missing, which is supposed to contain the material library.

I also ran across this thread where someone was having a similar problem with no Localization folder when they installed Rhino:


…which has this link:
https://wiki.mcneel.com/rhino/installingrhino/5.0
…which I followed, but didn’t have any luck. Still no Localization folder on my computer.

Any other suggestions?


(Pascal Golay) #4

Hi Joel - so, you did this thing, correct?

Download a fresh full installer from the Rhino Downloads page. Follow these instructions to uncompress the downloaded Rhino 5 EXE into a folder.
Browse to the Installer folder.
Run the LanguagePack_XX-XX.msi

And no action? Have you tried running as Administrator from the Rhino icon?

-Pascal


#5

I’m not familiar with running as Admin, but I did the rest of the suggestions with no effect–still no Localization folder.


(Pascal Golay) #6

Hi Joel - sorry - right click on the Rhino icon and choose ‘Run as Administrator’, if that is available. Any different?

-Pascal


#7

Thanks, but no change, still no Localization folder. I could try putting that folder and its contents from a different computer onto a USB drive and just load it onto this newer computer and see what happens. Won’t be able to try that until tomorrow morning.


#8

I’ve also realized I’m missing in-program Help–F1 launches a web-based help system instead of Rhino-based.


#9

Somehow it’s working now.

Tried the whole process again for what I thought was about the 3rd or 4th time, but this time it worked, so apparently I hadn’t followed the steps quite perfectly.

  1. Ran the file called LanguagePack_en-us.msi from the files I had previously unzipped per the previous link’s directions.
  2. Opened Rhino.
  3. Ran ToolbarReset command.
  4. Closed Rhino.
  5. Opened Rhino.
    5b. Magic happened.
  6. Checked for materials, and now they exist.
  7. Checked for in-program Help, and now it exists.
  8. Checked my computer for the Localization folder, and now it exists too!

Thanks for your time and help Pascal.


(Pascal Golay) #10

OK, I’m glad it’s sorted out.
-Pascal