Cycles - there is no rendering Rhino Mac - Metal

with the change of the renderenginge to CyclesX I don’t get any rendering anymore. (MAC Version)
The viewport of the renderpanel shows a full transparent rendering (no matter what channel is activated)

I think this has something to do with my graphics card - the radeonPro 460 and Metal because I seen a significant slowdown in the WIP Version (in 2D Drawings) at the moment of the change to the Metal Interface (normale the 460 should a metal capable Card but one of the first “full metal cards” I think). The Version 7 is way faster in OpenGL mode in 2D drawings but maybe this is an other construction side :slight_smile:
But the renderproblem also exists if I change the rendermode to CPU.

Here ist my System:

Rhino 8 SR0 2023-8-15 (Rhino WIP, 8.0.23227.12306, Git hash:master @ 1c08cfad3cf1091b87da2d9643585abee78578d9)
License type: Kommerziell, Build 2023-08-15
License details: Cloud Zoo
Expires on: 2023-09-29

Apple macOS Version 12.6.8 (Build 21G725) (Physical RAM: 16Gb)
Mac Model Identifier: MacBookPro13,3
Language: de-DE (MacOS default)

AMD Radeon Pro 460 OpenGL Engine (OpenGL ver:4.1 ATI-4.8.101)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: ATI Technologies Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB
Graphics: AMD Radeon Pro 460
Displays: LG UltraFine (217dpi 2x)

Metal GPU Family Apple 0
Metal GPU Family Common 3
Metal GPU Family Mac 2
Graphics processors
Intel HD Graphics 530 (1536 MB)
AMD Radeon Pro 460 (4 GB)
LG UltraFine (2560 x 1440)

USB devices
Apple Inc.: Apple T1 Controller
LG Electronlcs Inc.: LG UltraFine Display Camera
LG Electronics Inc.: USB Controls
LG Electronics Inc.: USB Audio

Bluetooth devices

Third party kernel extensions
com.seagate.IOSED01 (50) 42D11973-967A-3CE6-8554-0EA15CB55353
com.highpoint-tech.kext.HighPointIOP (4.4.5) 571AEA63-3845-3A83-B37F-5FD117C0FFDE
com.highpoint-tech.kext.HighPointRR (4.22.1) 6DF47B93-DB65-36BD-9392-0101CFDDDDFF
com.softraid.driver.SoftRAID (6.0) CBBE85C9-E1A8-3C3B-A4D3-DC690B0898D8

Third party plugins
/Users/pascalheussner/Library/Application Support/McNeel/Rhinoceros/packages/8.0/IntelDenoiser/0.6.7/libtbb.12.dylib
/Users/pascalheussner/Library/Application Support/McNeel/Rhinoceros/packages/8.0/IntelDenoiser/0.6.7/libOpenImageDenoise.1.4.3.dylib

Rhino plugins that do not ship with Rhino
/Users/pascalheussner/Library/Application Support/McNeel/Rhinoceros/packages/8.0/maxwell_rhino/Maxwell for Rhino/maxwell_rhino_8.rhp “Maxwell for Rhino”
/Users/pascalheussner/Library/Application Support/McNeel/Rhinoceros/packages/8.0/AMDDenoiser/0.5.3/AMDDenoiser.Mac.rhp “AMDDenoiser.Mac”
/Users/pascalheussner/Library/Application Support/McNeel/Rhinoceros/packages/8.0/IntelDenoiser/0.6.7/IntelDenoiser.Mac.rhp “IntelDenoiser.Mac”

Rhino plugins that ship with Rhino
/Applications/ “Renderer Development Kit” 8.0.23227.1002
/Applications/ “Commands” 8.0.23227.12306
/Applications/ “Snapshots” 8.0.23227.1002
/Applications/ “RhinoCodePlugin” 8.0.23227.12306
/Applications/ “RDK_EtoUI” 8.0.23227.12306
/Applications/ “MeshCommands” 8.0.23227.12306
/Applications/ “Rhino Render” 8.0.23227.12306
/Applications/ “RhinoCycles” 8.0.23227.12306
/Applications/ “SectionTools” 8.0.23227.1002
/Applications/ “Vorgänger Rhino-Renderer” 8.0.23227.1002
/Applications/ “Displacement” 8.0.23227.1002
/Applications/ “PanelingTools” 8.0.23227.1002
/Applications/ “IronPython” 8.0.23227.12306
/Applications/ “Grasshopper” 8.0.23227.12306

It seems that these card is just capable of Metal2 and not Metal3 → maybe this is related?!

  • and maybe it is time for an silicon one :slight_smile:

in raytraced mode the viewport looks totally fine:
I also seems that these mode use the gpu.

I believe @DavidEranen has a fix for this.

1 Like

I think now I found a related thread:

Hello HigoIII or Nathan,
I looked at your data and saw nothing that related to my machine. I tried both the CPU and the GPU and got the same result, no image. Can you be more specific as to how your info relates to my machine, I already sent my info in a prior email.

The data point that corresponds between the two is the AMD GPU.

According your system info Rhino 8 WIP renderer Mac not working - #4 by Joe_Neill you both have this issue.

As mentioned @DavidEranen has a fix for this. I imagine it will be available in a next WIP update.

1 Like

OK, I didn’t understand that the fix was for the next update. I hope it works.

Envoyé de mon iPhone

Hello Nathan,
I tried the renderer. For the moment it works but it is not stable. First the lighting of my drawing was not the same as in the rendered view or raytrace and after a test of 150 samples Rhino crashed. Also, when opening the « render properties » window the render category closes and I have to open another category then choose render again to see the parameters. One other thing, why so many changes in the way things are used in relation to R7? Most frustrating.

Hi Nathan,
I don’t know if you saw the previous email but the lighting problem is me. My apologies.

Me again. I tried rendering my drawing, it works, I saved the drawing then a couple of minutes later Rhino crashed.

Well Nathan another drawing and another crash. I tried a different drawing to see if the previous one was corrupted but this time Rhino crashed before the rendering was completed. As with the previous draxing I was using final quality at 6000x6000 pixels. I also zoomed in and out to better see the drawing.

Hello again Nathan,
I tried rendering a drawing made with R8 and Rhino did not crash. The other two were drawings in R7. I did not save them in R8 before rendering.

in my Case (with the WIP from today (203-08-22) - I get a render Output- and the gpu rendering is way faster than the CPU - thank you