Rendering speed

rendering

#1

Rendering speed is painfully slow. So slow on highest quality setting that I’ve never even waited long enough for the image to start to appear.

I’m using a 2018 MacBook Pro 13" so a fairly modern machine.

I’ve gone back to using v5 for the time being because I need to actually produce something.


#2

Same here, didn’t even see cycle’s first pass.
I don’t rely on my Mac to deliver stuff and I don’t believe anything will change soon.


(jesterKing) #3

Are we talking here Rhino Render, or the Raytraced viewport mode?


#4

Raytraced, at least for me.


(jesterKing) #5

Does a simple box start ok with Raytraced?


#6

Knowing from Windows version yellow bar changes to grey when Cycles start rendering.
In Mac there is still yellow bar, but box seems to be rendered.
Simple box without any scene or environment set makes my computer unresponsive for about a minute (and I deal with huge number of elements).


#7

Just to add: WiP struggles to quit now.
Forced quit applied :frowning:


(Nathan 'jesterKing' Letwory) #8

Please post the output from the Rhino command RhinoCycles_ListDevices (check command history). No need to change to Raytraced mode to run that command.


#9

Command: RhinoCycles_ListDevices
We have 3 devices

Device 0: CPU > Intel Core i7-7920HQ CPU @ 3.10GHz > 0 | False | True | CPU
Device 1: OPENCL_Apple_Intel(R) HD Graphics 630_ID_0 > Intel HD Graphics 630 > 0 | True | True | OpenCL
Device 2: OPENCL_Apple_AMD Radeon Pro 555 Compute Engine_ID_1 > AMD Radeon Pro 555 Compute Engine > 1 | True | True | OpenCL

BTW, I’m reporting two minor, but annoying things.

  1. Single click to maximise the viewport doesn’t work
  2. In all other versions Rhino displays arrow pointer when no command is activated, Wip displays crossed pointer constantly as to draw the line.

(Nathan 'jesterKing' Letwory) #10

Under Preferences check the Cycles section. Let me know what device is selected.

If it is not the Radeon Pro you should check that. If it is well, then the following also holds:

When you switch to Raytraced for the first time Rhino needs first to compile the kernels for it. That will take some time, but should complete in due time. In our office we have one Radeon Pro mac, and it renders once those kernels have been compiled. Unfortunately for those there isn’t any useful progress anywhere, something I haven’t been able to solve as of yet. It can take many, many minutes, so with this I can only advice patience. Once the kernels have been compiled the rendering should be able to start. If you abort the compilation by switching away to some other mode, or (force) quitting Rhino you’ll find you have to sit through the entire wait again.

But once the kernels have been successfully compiled it should not need to do that anymore the next time you switch to Raytraced.

If you don’t feel like waiting for the compile you can always select the CPU as your render device.


#11

Interesting re cycles, but my original post was about Rhino Render.

I’ve reverted to Rhino 5 which renders at similar resolution and smoother images in a fraction of the time. Granted, some of the softer shadows from WIP are a bit nicer but the grainyness of the images at quality settings where I have the patience for it to actually produce something are just not worth the very lengthy wait.


#12

@nathanletwory any thoughts on the original problem I noted? This thread seems to have been diverted to a discussion about cycles.


(Nathan 'jesterKing' Letwory) #13

I think this is due to skylight support in Rhino Render, but I am not too familiar with that, especially not on the mac. Anyway, I don’t see any way of tweaking the Rhino Render advanced settings (@maxsoder, is that correct - not yet implemented?) , so maybe disabling skylight gives you speed improvement.


(Max Söderström) #14

Yes that is the case, the Advanced section that Rhino Render implements is not yet available on the Mac.


#15

One thing I found to speed things up somewhat was to turn off ground plane. I guess it results in fewer rays of light bouncing around?


(Pascal Golay) #16

@robinp how about turning off the skylight (lights panel)? That is on by default in V6, not in V5.

-Pascal


#17

Hi Pascal

I have skylight on in both V6 and V5. Yes it does slow them both down. V6 renders are now usable if still much slower than V5 but they are also much nicer.

I really do wish there was a better / more reliable interface for dealing with tone mapping. The settings for it seem flakey and often the entry boxes in the logarithmic option don’t tell you accurately what the current settings are making it quite difficult to tweak.

It would be nice if there was an auto ‘make it look nice’ button which set the controls including in such a way that you can actually see what numbers are set. You could then tweak away from that to make minor adjustments.

Robin