Cycles/Sub-D bug

Hi @nathanletwory
I’ve been seeing this a couple of times, and this time I remembered to save the file. Sometimes - for reasons still unknown - Cycles decides to render what seems to be the welded mesh cage of a sub-d, rather than the actaul render mesh - see the attached screen grabs.

It seems to be file specific, and goes away if I copy/paste or import the file into a clean file. And as mentioned, I’m still not quite sure what I’ve done to make it happen, but it IS something that “happens”, meaning that the file is all good in the begining, and then goes awry.

I was hoping, that maybe the 3DM file could be of use to find out what’s happening and will of course report it, if I find out what I do “wrong”.

Rendered viewport

Raytraced viewport

cycles bug.3dm (5.6 MB)

Regards, Jakob

Hi Jakob - thanks, I see that here.
@Normand - this seems to be controlled, for raytracing but not Shaded or Rendered, by the meshing setting in DocumentProperties > Mesh >Detailed controls > ‘SubD meshing parameters’:

You need to change the view to wireframe and back to raytraced to see the change… something is not working right in all of this…

RH-62212 SubD meshing parameters: Cycles vs Shaded

@Normand - it turns out there is a bit more to this - Cycles is indeed paying attention to the SubD meshing parameters, but only because it cannot, yet, smoothly render SubDs using the same tricks as OpenGL uses for Shaded/Rendered etc. - eventually it will, and this difference in display will go away.


FWIW Cycles is relying on the changequeue mechanism provided by the RDK for all mesh geometry, including those generated for SubD objects.

Any engine built on top of the changequeue mechanism will behave the same way.

Anyway, Jeff made a change in the wording of the slider text, so it is clear what it is used for.

Hi @pascal and @nathanletwory
Thanks, both of you! I had NO idea that this slider existed (and usually don’t mess much with the render mesh, as I have them set pr. custom template). I’ve just checked my custom “product design” template - lo and behold, the slider was set to minimum. I must’ve missed the memo on the separate setting for Sub-D’s. Sorry for the hazzle!

RH-62212 is fixed in the latest Rhino 7 Service Release Candidate