Cycles makes an interesting image

cycles

#1

Hi,

this is shaded:
image

And this is Cycles:
image

The file:
Test.3dm (63.7 KB)

What is the cause for the special style?

Charles


(Wim Dekeyser) #2

See this thread:


#3

Hi Wim,

thanks for the hint.

@nathanletwory
The above is also on a GTX1060.

Charles


(Nathan 'jesterKing' Letwory) #4

There seems to be a precision problem with some files. For now try setting a larger unit setting. If you are working in mm, then try i.e. cm or m and apply the suggested scale action.

https://mcneel.myjetbrains.com/youtrack/issue/RH-40378 and https://mcneel.myjetbrains.com/youtrack/issue/RH-40537 track the progress on this problem.


(Wim Dekeyser) #5

Can you make RH-40537 visible to the public, Nathan?


(Nathan 'jesterKing' Letwory) #6

@wim, I’ll ask @pascal, he created the issue with some of his work - but it is essentially the same as 40378, just slightly different.


#7

If you are working in mm, then try i.e. cm or m and apply the suggested scale action.#

Hmm, the largest value is 3863…

Ok, I switched to cm.
In Shaded view, I can see the 2 objects.
After I set Raytraced, I get nothing but a white viewport.

Then I tried _RefreshShade.
Still the same.

Same for meters.


Next surprise.
I think this has nothing to do with Cyles.
Or perhaps it has?

In Wireframe, the 2 object are completely invisible.
When 1 object is selected, and I then switch to Wireframe, I can see the selected one.
But not the one next to it.
image

(6.0.17227.14151, 15.08.2017)


(Nathan 'jesterKing' Letwory) #8

If it turns completely white you probably have a case where the environment and skylighting are all set to white. Change the backdrop to i.e. gradient, and you should start seeing your model.

The objects not showing properly in Wireframe is indeed something other than Cycles. If you look very closely you can see the color is something very, very light pink. For that I have created a new YT item: RH-40810.


(Pascal Golay) #9

@wim - You should be able to see that now.

-Pascal


(Gustavo Fontana) #10

I was taking screenshots of my work yesterday to send to a client. I was feeling fancy and tried Raytrace viewport. All models looked like faceted/chiseled ice sculptures. Not what I would expect at all. So I gave up for now.

Also equally frustrating: a metal material in rendered viewmode looks pitch black. :roll_eyes: (using the paint shader for now, but this should be fixed IMO)

G


(Nathan 'jesterKing' Letwory) #11

Something is indeed wrong here. I am currently investigating. The linked bug items in this thread are exactly that.

@DavidEranen, this is probably something for you to look into?


(Gustavo Fontana) #12

Hi Nathan,

I just updated V6 now after closing my last file to go to bed. Out of curiosity I relaunched my file again after updating to see if it’s fixed… and YEAH! it’s now rendering ok again. Just right after I sent all my work to the client as OpenGL, oh well :rofl:

G


(Nathan 'jesterKing' Letwory) #13

:open_mouth: That is magic. I haven’t committed any code changes for a couple of weeks…


(Gustavo Fontana) #14

that’s why. Code was looking for attention again.


(Gustavo Fontana) #15

This is also happening in Raytrace/Cycles. If I move the slider from polished to glossy I start seeing something.

…wait, I think I see why:

That’s ain’t a very cool default me thinks.

G


(Nathan 'jesterKing' Letwory) #16

That looks like broken environments. If you have had them from the environment library you may have to (re-)download the associated textures. You could use the DownloadLibraryTextures command to get all texture images for the material and environment library. Be advised it can take quite a while though. Probably something to let Rhino do overnight?


#17

@gustojunk
What is wrong with the defaults?

@nathanletwory
While we are at the defaults.
Don’t we need at least 2 colors for a gradient?
image

And how to select an image?
image

Charles


(Gustavo Fontana) #18

…never mind, I can’t even wrap my head around all this. I’ll keep using GL and Keyshot then. This is too high maintenance for now. Thx!

G


(Nathan 'jesterKing' Letwory) #19

The gradient is constructed from the solid color and the gradient color.

The wallpaper is UI-wise a sub-optimally implemented feature. The wallpaper is to be set in the view properties.


(Nathan 'jesterKing' Letwory) #20

I understand. I’ll let you know when things are supposed to be better.