Cycles crash


(Marc Gibeault) #1

In current WIP, if V-Ray is set as current render engine, when I select “Raytraced” in the viewport dropdown Rhino crashes instantly.


(Nathan 'jesterKing' Letwory) #2

Does that happen with any other render engine set as current engine too? I.e. Flamingo, Brazil, or Rhino Render?

What Rhino WIP version are you testing with now, the one from January 31st?

edit: If you are presented a crashdump upload dialog, please upload. In the comments please paste the URL to this topic and add @nathanletwory and nathan@mcneel.com . Thank you!

/Nathan


(Marc Gibeault) #3

As I said, the current WIP (6.0.17031.12411, 2017-01-31)
It crashes when current renderer is set to V-Ray, implying that when set to Rhino renderer it doesn’t crash. I don’t have other rendering engines installed.
That’s the only thing I have for you:


(Nathan 'jesterKing' Letwory) #4

That without

Isn’t too useful. There are those who have for reasons perhaps a different current WIP :slight_smile:

Anyway!

I’ll see if I can reproduce with the engines I have access to, if I can’t I’ll have to consider i.e. remote debugging. But lets see first if I can reproduce. It’ll probably Monday though before I properly can continue, hope that is ok!

/Nathan


(Nathan 'jesterKing' Letwory) #5

Actually, one question: does the crash happen even with an empty file (default template, not custom made), or with a file that has v-ray specific data in it?

Thanks.

/Nathan


(Marc Gibeault) #6

Yep, just tried this with a default template (small objects - inches), nothing added, and it crashes.


(Nathan 'jesterKing' Letwory) #7

Thanks. I’ll get back to this next week. I have created a YouTrack issue so we can keep this covered: https://mcneel.myjetbrains.com/youtrack/issue/RH-37934

/Nathan


(Nathan 'jesterKing' Letwory) #8

@Marc,

Does a crashdump file appear on your desktop with the crash? If so, could you send it to me?


(Nathan 'jesterKing' Letwory) #9

I have found the bug and fixed it. It will be available in the next WIP release.


(Brian Gillespie) #10

RH-37934 is fixed in the latest WIP


#11

raytraced /cycles still freezes. not fixed with todays wip.


(Nathan 'jesterKing' Letwory) #12

See my reply here.


#13

jep, sorry, thanks


(Nathan 'jesterKing' Letwory) #14

np, feedback is always good :slight_smile: