Cut an object in 2 pieces in Rhino?

I want to cut the blue/green/red in 2 where the yellow cutting plane is. I tried trim and split but both didn’t work… maybe I’m doing something wrong. By the way, the object i want to cut is grouped as 1 object.

What messages does Rhino show in the command line when you try to Split or Trim.

Grouping objects should not affect Split or Trim.

Are you selecting the objects in the correct order? For Split the objects to be split are selected first, then the cutting objects. Trim works opposite. First the cutting objects are selected, then the portion of the objects to be trimmed.

Use IntersectTwoSets to find the intersection between the objects to be split or trimmed and the cutting object. It is usually best if the current layer when running the command is different than the layers the objects are on so that the resulting curve can be easily seen. The intersection should be one or more closed curves and/or open curves which end at the edges of the objects to be split/trimmed.

Post the file here if you need further analysis of the problem.

I selected the objects in the right order for both Trim and Split. I don’t know why it’s not working.
My file is too large to upload.

What are the results of Intersect?

Have you tried Ungroup the objects to be split, and splitting each object separately?

What are the objects you are trying to Split? Are they surfaces, polysurfaces, solids or extrusions? Or are they meshes? Split and trim do not work on meshes.

One way around this is to explode the object you’re trying to split, it often highlights the problem part as others split or trim but one part in particular might not play ball.

Another way to see if there is an anomaly is to _Intersect the two objects and see what it returns… Sometimes the curves it punts out can be used to split the object rather than the intersecting surfaces.


1 Like

I tried Ungroup and that didn’t work either. The object I’m trying to split is a polysurface and the cutting plane is an extrusion.

I tried exploding and that didn’t work either. I also tried intersect and nothing happened.

Did you use Save Small and then perhaps zipped the file as well?

Ungroup and select one object to try splitting. If it splits then try splitting another object. Keep trying individual items until you find one which will not split. When you have found an object which will not split Export that object and that the cutting object to a new file which should be small enough to upload.

Other things that might help:

Check the tolerance
Check that the objects be not too far from the origin
ShrinkTrimmedSrf on the surfaces to split (this may also reduce the file size)
RebuildEdges on the surfaces to split
Rebuild the splitting plane with degree = 3

1 Like

If they’re closed polysurfaces maybe “wirecut” might work

If you tried Intersect and really nothing happened and there was not a command line error message, there is a problem. Normally the command line should report if any intersections are found and how many. If it says 0, then it thinks the objects do not intersect. If you see they clearly do, then there is perhaps a bug somewhere, please post (just) the objects in question (use Export selected, save small and Zip).


Hi Emilio,
If I want to change the tolerance would I make it tighter or looser?

Thank you

Hi Costa

Tighter, I usually keep it to 0.001 mm, when possible.
But for difficult intersections we may try an even tighter value …