Curves Visible Through All Surfaces

I’ve been working on a series of projects for a new client and every time I import their Adobe Illustrator generated lineart, all of those curves are visible through all surfaces in the rest of the Rhino session. I can’t figure out how to get those curve to stop doing that aside from rebuilding them.

In the screenshot those two V-shaped curves are in the center of the cylinder and should not be visible through it.

Illustrator_Curves_01.3dm (210.7 KB)

Try selecting these curves and running _ClearDrawOrder command; seems like the imported ones have some sort of property that makes Rhino always draw them in front…

Thanks for the info, that solved the problem perfectly!

McNeel: can we get an option somewhere to have this command run automatically when importing AI, DWG, DXF lineart? I don’t think we should have to know an obscure command in order make curves display in a normal fashion.

Hi Derek -

I can’t reproduce this issue with lineart exported from Rhino in the AI or DXF formats. We would need a sample to be able to check this.

I’ll bet it’s not obscure anymore to a user named Derek! :grinning:

This is true lol :slight_smile:

This morning I made a new session and imported all the lineart fresh to see what’s going on. The AI files all import with no issues, but it’s actually the SVG format files that are causing the issue. My mistake, it’s been a while and I forgot the exact details.

I can’t publicly share the SVG file here since it belongs to my client. Should I private message that to you?