Curves do not show up in any display mode

@sc4255
Please run SystemInfo again now that the driver update fixed the problem.

We’re trying to collect details before and after SystemInfo lists so we can do a better job of warning users about running drivers that are known to be bad.

Thanks

Hi John,

Sorry about the radio silence. For some reason I can’t update to the latest dch driver, I’m getting an error saying the update isn’t compatible with my OS, which seems weird. Will probably have to take the machine in.

Hi @sc4255

Can I get a better description of the problem you’re experiencing? As far as I can assume, it’s that you cannot see curves on your screen in any display mode…is that correct?

If that is the case…the first thing I would try (if you haven’t already) is to turn OFF “GPU Tessellation” from within Rhino’s OpenGL Settings page.

Go to Options->View->OpenGL and UNCHECK the option “GPU Tessellation”, at the top of that page

Now see if things display any better.

Thanks,
-Jeff

Hi there,
I just downloaded the free trial of Rhino 6 on my computer and I am having the issue of no curves on any display. Can someone walk me through what to do please!
thank you!

Hello -

Please run the SystemInfo command in Rhino and copy/paste the results here.

-Pascal

I think I figured it out! I went to “Go to Options->View->OpenGL and UNCHECK the option “GPU Tessellation”, at the top of that page” let me know if you think this worked as well.

Rhino 6 SR23 2020-2-24 (Rhino 6, 6.23.20055.13111, Git hash:master @ 8106edaa648ba209a8fc587f0f7fcccbaac09169)
License type: Evaluation, build 2020-02-24
License details: Cloud Zoo. In use by: Marissa Ravin ()
Expires on: 2020-06-10

Windows 8.1 (Physical RAM: 12Gb)
Machine name: RISSRAVE

Hybrid graphics system.
Primary display: Intel® HD Graphics 4600 (Intel) Memory: 2GB, Driver date: 12-20-2013 (M-D-Y).
Primary OpenGL: NVIDIA GeForce GTX 860M (NVidia) Memory: 2GB, Driver date: 2-2-2014 (M-D-Y). OpenGL Ver: 4.4.0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.4
Shading Language: 4.40 NVIDIA via Cg compiler
Driver Date: 2-2-2014
Driver Version: 9.18.13.3260
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.23.20055.13111
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hello - most likely you can find a somewhat newer driver for your video on the Intel & NVidia websites - please update the drivers for both (they are ancient) and then try with GPU Tessellation on.

-Pascal

can you point me in the direction of how to find a new driver?

Hello - first, check the Notifications panel on the right - (the bell icon) if that is not open open it from the Panels menu > Notifications. If, in that panel, there is a notification about your driver, then double-click on it and follow the dialogs.

Any luck?

-Pascal

I can`t do lines or circle, how can I fix this problem? Can someone please help me? I can put points tho.

Hi -

Could you start by running the Rhino SystemInfo command and copy-pasting the result here?
-wim

Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06341, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Evaluation, build 2021-11-09
License details: Stand-Alone
Expires on: 2022-01-09

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Unplugged [38% battery remaining] ~57 minutes left

Standard graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 520 (Intel) Memory: 1GB, Driver date: 11-18-2015 (M-D-Y). OpenGL Ver: 4.4.0 - Build 20.19.15.4326
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.4 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.4
Shading Language: 4.40 - Build 20.19.15.4326
Driver Date: 11-18-2015
Driver Version: 20.19.15.4326
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi -

That is not going to work very well. The recommended amount of VRAM is 4 GB and a dedicated GPU. You should at least try to update the drivers for that Intel GPU. Open the Notifications panel in Rhino and follow the links to the site where you can download those.
-wim

thanks, i update my drivers but still didn’t work. I guess i can’t use rhino7 on my laptop.

Hi -

There is one more thing that you could try - in the Options panel, go to the View > OpenGL page. There is a “Level” slider that is currently set to “Max OpenGL Available”. Move this slider one notch to the left and restart Rhino. Check if that made a difference. If not, move the slider another notch to the left and restart - and so on.
-wim