Cursor selection Offset with M1 test metal

Hello just trying out the Wip and have an issue with the cursor selection being offset when in single view mode or layouts but works as expected when in 4 view mode with test metal enabled works fine always in open gl.

test metal does seem generally slower at the moment, looking forward to performance improvements.
Cheers Quinn.

Ive had 5 minuets to add some additional info and could really do with some help any one out there ?

I have a persistent problem with any new or current rhino WIP file. and has bee so since November 2022 regardless of updates.

I open a new or existing file
When I’m in the four pane view the section cursor works as expected if I drag left to right across an object or curve I can select it if I drag right to left partially across and object or curve I can select it and the cursor reacts accordingly.

Then if I switch to a single view top, perspective, front or right and try to select the object or curve the same way the by draging left tot right or right to left the position of the cursor is correct but the selection box created is offset and so the the item is not selected.

this happens with every file.

I don’t think this is supposed to happen I would like it to select things when I drag across them in which ever view I like.

I hope some one on here can help this is quite annoying and stopping me from really getting stuck in to the wip.

Rhino 8 SR0 2023-5-30 (Rhino WIP, 8.0.23150.18306, Git hash:master @ 7b3e0d7a9309922dde58208626f2e78df5122ced)

License type: Commercial, build 2023-05-30

License details: Cloud Zoo

Expires on: 2023-07-14

Apple macOS Version 13.4 (Build 22F66) (Physical RAM: 16Gb)

Mac Model Identifier: MacBookPro18,1

Language: en-GB (MacOS default)

Apple M1 Pro (OpenGL ver:4.1 Metal - 83.1)

OpenGL Settings

Safe mode: Off

Use accelerated hardware modes: On

Redraw scene when viewports are exposed: On

Anti-alias mode: 4x

Mip Map Filtering: Linear

Anisotropic Filtering Mode: High

Vendor Name: Apple

Render version: 4.1

Shading Language: 4.10

Maximum Texture size: 16384 x 16384

Z-Buffer depth: n/a

Maximum Viewport size: 16384 x 16384

Total Video Memory: 10922 MB

Graphics: Apple M1 Pro

Displays: Unknown (108dpi 1x), Unknown (255dpi 2x)

Metal GPU Family Apple 7

Metal GPU Family Common 3

Metal GPU Family Mac 2

Graphics processors

Apple M1 Pro

BenQ PD2705Q (2560 x 1440 @ 60.00Hz)

Color LCD (1728 x 1117 @ 120.00Hz)

USB devices

3Dconnexion: SpaceNavigator

Generic: 5-Port USB 2.1 Hub

Apple Inc.: iPad

Bluetooth devices


Third party kernel extensions


Third party plugins


























































Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino

/Applications/ “RhinoCycles” 8.0.23150.18306

/Applications/ “SectionTools” 8.0.23150.1002

/Applications/ “Snapshots” 8.0.23150.1002

/Applications/ “RhinoRoslyn” 8.0.23150.18306

/Applications/ “Constraints UI” 8.0.23150.18306

/Applications/ “Grasshopper” 8.0.23150.18306

/Applications/ “PanelingTools” 8.0.23150.1002

/Applications/ “Commands” 8.0.23150.18306

/Applications/ “Renderer Development Kit” 8.0.23150.1002

/Applications/ “RhinoCPython” 8.0.23150.18306

/Applications/ “RDK_EtoUI” 8.0.23150.18306

/Applications/ “Displacement” 8.0.23150.1002

/Applications/ “Rhino Render” 8.0.23150.18306

/Applications/ “IronPython” 8.0.23150.18306

/Applications/ “Legacy Rhino Render” 8.0.23150.1002

/Applications/ “RhinoCodePlugin” 8.0.23150.18306

Rhino wip selection bug .3dm (40.3 KB)

Are you using an external monitor? We are getting a bug fixed that looks like this with regards to external monitors fixed as I type this reply.

Yes I am,
and that does solve the issue I just tried it, unplugged from the external monitor :slight_smile: and it works as expected thanks so much.

Great; this should be fixed in next week’s WIP

cool I look forward to that, also as a side note it works even if I just pull the window on to the laptop display with out unplugging the external monitor, wish I had tried that earlier and thanks for the rapid response.