Cursor appearance in Rhino Mac

Forgive me if this question has been asked before and/or it has been dealt with before. I could not find an answer I am looking for in the forums.

Whenever I want to do almost anything in Rhino, be it Move, Scale, Fillet edges, Rotate, etc., and I have to use the cursor, instead of a cursor looking like an arrow, the cursor always looks like cross hairs with 4 short while lines with a open space in the center.

However, after those cross hairs appear, I can make them disappear each time by briefly panning inside any of the view ports or rotating the Perspective viewport.

I find the cross hairs cursor somewhat difficult to work with. Is there a way to always have the “arrow cursor” as the default cursor?

Not sure if you’ve seen this from the Mac manual (http://docs.mcneel.com/rhino/5/usersguide/osx/en-us/Default.htm):

There are two parts of the cursor: the cursor (1) and the marker (2). The cursor always follow the mouse movement.
The marker sometimes leaves the center of the cursor because of some constraint on it such as grid snap or ortho. The marker is a dynamic preview of the point that will be picked when the left mouse button is clicked.

When the marker is constrained, in elevator mode, for example, a tracking line (3) also displays.
Constraints move your marker to a specific point in space or make its movement track according to the constraint so you can model accurately.

The cursor looks like you describe when I model a new object, like a polyline, circle, polygon, etc.

But when I want to do one of the commands as I listed in my original post like Move, Scale, Fillet edges, Rotate, etc., I only see the cursor as I described it. And when I pan in any of the viewports or rotate the view in the Perspective viewport, the cursor changes to a black arrow cursor.

Is it possible to always make the cursor look like a black arrow during the commands I described and other commands?

Do you have object snaps turned on?
Can you post a screenshot of your Rhino window so we can see it, too?

I have object snaps turned on. I will post an mp4 movie which would explain the issue better.

When running commands like Move, the cursor should be the crosshair cursor. You are potentially picking points in your model, and Rhino always displays the crosshair cursor when picking points. There is no option to change the cursor to an arrow cursor when picking points.

It is a bug that the cursor changes from a crosshair cursor to an arrow cursor after panning or rotating a view. The cursor should change back to a crosshair cursor when you are finished manipulating the view. Logged as a bug.

Thank you Marlin,

That answers my question. Too bad it’s a bug, I like the arrow better during certain commands than the crosshair cursor.

This does bring me to another question. Often, after I have completed a command, the crosshair cursor stays on the screen and I have to hit the esc key to make it disappear. Is that also a bug?

Yes, that’s a bug. The cursor should always revert to an arrow at the end of commands. If you can reliably repeat this, please describe a set of steps I can follow so I can find this and fix it.

Here are some examples of the issue with the crosshairs cursor remaining after certain commands, that I can replicate.

Please note that in the following examples in Rhinoceros/Preferences/Modeling Aids/Cursor ToolTips, Enable cursor tooltips is checked, and below it Osnap, Distance and Command prompt are also checked.

With these settings all the “Box” creation commands, like Solid/Box/Corner to Corner, Height display the crosshair cursor issue. No matter whether you input numbers or just drag the cursor to create the box. When the box is complete you see the crosshair cursor with a balloon below it that says “Height, Press Enter to use width” When I then press enter, the program wants to repeat the command to make another box. Only when I press “esc” does the curser revert to an arrow.

This also happens when creating any of the other Solids.

The same thing happens when for instance I do Solid/Extrude Surface/To Point (or any of the other three options). At the end of the command the balloon below the cross hair cursor will say “Point to extrude to, …” When I hit enter, the command repeats. When I hit “esc” the cursor changes to an arrow.

There are other commands with which this happens, I cannot remember all of them right now. I can also replicate this with Boolean Difference as well as Solid/Fillet Edge/All three options.

When I uncheck “Enable cursor tooltips” in Preferences/Modeling Aids/Cursor/ToolTips (including everything below it) or uncheck just “Command prompt” this crosshair cursor behavior does not happen. However, something else is different also. With the option(s) unchecked the cursor is never crosshairs, but always an arrow.

Please let me know if you can replicate this. If you can’t, I’ll make a movie and send it to you.

Zews, i have seen the same thing happening. The tool tips were a little quirky and staying on the screen even after the command was completed and you have to hit esc every time to get out if it. I turned the tool tips completely off and no longer use them.

I am not able to reproduce this here with cursor tool tips turned on. No need for you to create a movie; I believe it is happening for you, but I need to duplicate it to find the cause.

There are probably additional conditions that cause this to happen. Please post your OpenGL settings.

Also, please send me a copy of your preferences. Use the procedure described here http://wiki.mcneel.com/rhino/mac/resetprefs to make a copy of your preferences. Compress your saved preferences before sending and send the compressed file to marlin@mcneel.com. I can try duplicating this using your saved preference file. Thanks.

Here are my OpenGL settings:

Software information

Software versions
Rhinoceros version: 5.0 Wenatchee 2014-07-28 (519)
OS X version: Version 10.7.5 (Build 11G63b)

Plug-ins
None

Hardware information

Computer hardware
Hardware model: iMac7,1
Processor: Intel Core2 Duo CPU T7700 @ 2.40GHz
Memory: 6 GB
Architecture: Intel 64 bit

Video hardware
Graphics: ATI,RadeonHD2600 256 MB
Memory: 256 MB
Screen size: 1920 x 1200
Displays: iMac

Third party kernel extensions
com.Logitech.Control Center.HID Driver (3.9.0)
com.AmbrosiaSW.AudioSupport (4.0)
com.parallels.kext.prl_usb_connect (7.0 15055.740667)
com.parallels.kext.prl_hypervisor (7.0 15055.740667)
com.parallels.kext.prl_hid_hook (7.0 15055.740667)
com.parallels.kext.prl_netbridge (7.0 15055.740667)
com.parallels.kext.prl_vnic (7.0 15055.740667)
com.parallels.filesystems.prlufs (2010.12.28)

USB devices
Canon: iP6700D
Apple Inc.: Built-in iSight
Apple Inc.: Bluetooth USB Host Controller
Apple Computer, Inc.: IR Receiver
Logitech: USB Receiver

Bluetooth devices
Broadcom: Apple Wireless Keyboard

OpenGL information

OpenGL software
OpenGL version: (null)
Render version: (null)
Shading language: Not supported
Maximum texture size: 0 x 0
Z-buffer depth: 24 bits
Maximum viewport size: 0 x 0

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: None
Mip map filtering: None
Anisotropic filtering: None

I have also sent you a copy of my preference file.

I was able to duplicate this problem and it will be fixed in the next WIP release.

Thank you Marlin. I am looking forward to the next update.

It makes me happy that I was able to contribute in some small way making Rhino 5 Mac better.

I have a couple of other issues that I will post about separately in new topics. One of them is a bit more complex, and I need to illustrate the question with screenshots. Is it possible to upload screenshots to do this?

Marlin,

I’m a rhino developer. I will move to the mac (from developing PC applications) in the not too distant future.

I am writing because I’d like to flag the usefulness of having a more elaborate cursor class so that one can more easily set the appearance of a cursor in the viewport (for plugin applications). An example for the usefulness of this would be to enable a roll over type interaction to enable a better UX experience - ideally that would work on both mac and pc platforms.

I hope that you can take this on board.