Creating SubD Shoe Last with Creased Bottom Edge

I’m trying to convert a shoe last polysurface into a SubD object while maintaining the sharp edge on the bottom (crease). But the crease isn’t getting created. Attached is the 3dm file and below is a screenshot of the options I’m using in the QuadRemesh command.

I’ve been able to get around this issue sometimes on other shoe lasts by exploding the polysurface, rebuilding the bottom patched surface with no trim, moving it up and retrimming everything, joining and recreating the SubD. But on this shoe last not even that works.

Any suggestions on how I can get this shoe last to SUB while maintaining the sharp bottom edge as a crease?

Thank you,

QuadMeshCreaseTest.3dm (1.9 MB)

Have you tried the option ‘Use Surface Edges’ set to smart?

All that’s left to do is select the two loops and set all of them to be creased.

9 mm topology looks good. With 10 mm, not so much…

Setting ‘Use Surfaces Edges’ to ‘Smart’ helps. It gets the crease into the heel and the toe, but not the arch (pic below).

I also tried creating the crease afterwards by selecting SubD edges near the bottom edge curve and using crease command. The crease is created, but it doesn’t result in a smooth surface similar to the original.

Any suggestions?

Thank you for the help,

After creating the SubD with Quad Remesh you can select the entire edge loop and crease it.

QuadMeshCreaseTest.3dm (1.1 MB)

Just noticed you’re not using interpolate subD. Unfortunately, I have to interpolate because I need an accurate representation of the original model (without further increasing quad mesh count)… And as soon as I turn on interpolate subD, the crease method you’ve shown me gives some odd results… Otherwise your solution would be perfect…

Suggestions how to get a good SubD with bottom edge creased while still using interpolateSubd?

Thank you kindly for your help,

Sorry I didn’t notice you had the interpolate option on.

You might want to change your topic title to “Quad Remesh Interpolate SubD creased edge problem”