CreaseSplitting disabled as default - how?

Is it possible to have CreaseSplitting disabled as the default when starting Rhino? I’m currently working on a project with surfaces which are degree 1 and multispan in the V direction which I need to keep as such, not have converted to polysurfaces. It is a nuiscance to take time and and disable CreaseSplitting every time I start Rhino, and disruptive when I forget to disable it to later have to undo a command which triggered crease splitting, run the CreaseSplitting command to disable crease splitting, and then repeat the work I just did.

CreaseSplitting enabled or disabled default behavior should be able to be set in Rhino Options, similar to the default behavior for numerous other functions.

Hi David - for now, you can add a macro to your startup commands in Options:

`_CreaseSplitting _Disable’

Actually there is an advance option setting as well.

I need to check to see if it sticks between sessions though. The idea is mostly we want users not to be able to set this too easily - that is why it’s not in your face in Options.


I was anticipating that response. But I’d prefer to set the desired behavior in Rhino Options. It should be quick to add for V7. Can it be added to the list?

I’ll try changing it in Advanced options.

Hi David - you may need to run CreaseSplitting once in the current session to see it.


Still not there.

Curious - why the concern about keeping this option hidden from almost all users when other options which can confuse and bewilder users are easy to change in Options?

Hello - I guess the concern is that this option messes with geometry and leads to unexpected results, most obviously in shaded displays, but also in failing geometry operations. We saw a fair amount of mystery when for some reason (a plug-in , we suspect) the setting was disabled ‘on its own’ from time to time in V5.


I still can not find that option. What would be needed to make it easily accessible?

My opinion is that the default of automatically changing a valid single surface which is degree 1 in one or both directions into a polysurface when not needed constitutes messing with the model. I understand the rationale to have automatic splitting of creased higher degree surfaces, but the degree 1 surfaces by definition are only position continuous between spans. That is different than creases in a higher degree surface which require multi-knots or stacked control points.

Hi David - just by way of example - too many things just don’t work well with these:

KinkedDegree1.3dm (411.4 KB)

Not to mention FilletEdge confusion on the kinks - 'Why can’t I fillet the corners on my box?" sort of thing…


Pascal, I’m not asking that CreaseSplitting be disabled as the general default, only that the user have the option to set “Disabled” as the default for themselves by changing a setting in Options. Even the ability to set it in “Advanced” area would be helpful but that is apparently unavailable to ordinary users such as myself.

(Rest of diatribe deleted.)

Hi David - I don’t know yet why this is not available in your advanced options… But I understand what you’re asking - my example was to indicate what could go wrong if this is set by default and users forget or don’t know what they are doing - I believe the defaultness is due to this sort of thing and I don’t disagree with that behavior, myself. At any rate, I think it’s a rare enough need that a startup command is not unreasonable(?) Meanwhile, I’m trying to find out why you do not see the advanced setting…

@davidcockey, @wim - OK - so I have this setting due to my settings being migrated over the months and years from before this YT item was made and fixed :
Presumably at some point in testing I set this value prior to the fix and that wrote it into my settings.


FWIW, I’m not seeing that advanced option here. Not after first running CreaseSplitting either.