Simplified Surfaces and CreaseSplitting

I’ve been having some issues with some surfaces generated in Rhino and Grasshopper - they seem oversimplified. Rather than dividing at curvature discontinuities, Rh/Gh (somewhat unpredictably) generates single surfaces.

These can’t be exploded, but can be broken down using the DivideAlongCreases command.

This suggests that surfaces like this could be avoided by setting CreaseSplitting to “enabled,” but that’s currently not the case. The geometry in the screenshot (and 3dm) was generated with CreaseSplitting enabled (and Isoparms off to see the surfaces more clearly).

Why it matters:
This type of surface is problematic for the CAM software I use when part of an STP file. The software is unable to recognize and tool these surfaces accurately. The same problem came up with a contractor using different software, so it is not a unique problem.

Geometry in the file was generated in the attached Grasshopper. It also includes my current workaround, exploding curves in Grasshopper prior to extrusion.

CreaseSplitting_OrNot.3dm (152.5 KB)
CreaseSplitting_OrNot.gh (11.0 KB)

related to conversation on CreaseSplitting: (CreaseSplitting disabled as default - how?)

Hi Jokamm - The Rhino command ‘ExtrudeCrv’ has a ‘SplitAtTangents’ command line option that if set to Yes and UseExtrusions command is set to ‘Polysurface’, should control this as you need.If UseExtrusions=Extrusions then splitting always happens.

-Pascal

As for the Grasshopper part of this - GH doesn’t expose the SplitAtTangents option and defaults to having this off. So, the correct workflow is as you describe:

[Except, of course, that it makes more sense not to join first and then explode afterwards before extruding the curves].

This is a real bummer.
Please, @DavidRutten, expose this crease splitting option for extrusions in GH2.
An option to cap extrusions would also be greatly appreciated, as well as bi-directional extrusion.