Crash when closing file


#1

Since the latest release, which I downloaded something like a week ago or so, I get a crash when I close Rhino. It doesn’t happen when I close rhino without doing anything in Rhino. Only after closing Rhino after I already saved a file.

Here’s a copy from the problem details:

Problem signature:
Problem Event Name: APPCRASH
Application Name: Rhino.exe
Application Version: 6.0.16348.9381
Application Timestamp: 58503a35
Fault Module Name: StackHash_b51e
Fault Module Version: 6.1.7601.23569
Fault Module Timestamp: 57f7c06e
Exception Code: c0000374
Exception Offset: 00000000000bf3e2
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 2057
Additional Information 1: b51e
Additional Information 2: b51e8024c3d7925f827c146a89eb13af
Additional Information 3: f488
Additional Information 4: f488db33ca18a8638ee9fa4e631139c5

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\windows\system32\en-US\erofflps.txt


(John Brock) #2

Where are you storing your existing files?
If it’s anything other than your local hard drive, see if you have the same problem editing existing files on your C:\ drive.

I suspect rights issues with the little creating/deleting/renaming dance Rhino does when saving an existing file.


#3

I’m storing them on my local hard drive…


(John Brock) #4

Can you edit and save an existing file on your Desktop?
Are you running any third-party system protection tools?
Have you check the rights on the local folder where you are storing files to see if they have changed?


#5

When I edited and saved a file to desktop the same thing happened. It doesn’t happen when it’s saving though. Just when I close the software after I’ve saved. So when I open the file, I didn’t lose anything.

When I then open that file on my desktop and close it again, there’s no crash.

But when I open the file, edit, save and close the software, it crashes again.

I have bitdefender, if that helps in any way?


(John Brock) #6

I’ve never heard of BitDefender and no one else has reported his so I’d try temporarilydisabling it and see if the problem goes away.


#7

I turned bitdefender off. I tried reopening the file on the desktop, edit, save, close. Nothing happened, no crash. I tried it again with bitdefender still being off; open, edit, save, close. “Rhinoceros 6 Developer Build has stopped working”. So it didn’t work…


(John Brock) #8

Rats.
I’m out of ideas.

I assume you are running the current WIP from last week:
rhino_en-us_6.0.16348.09381.exe


#9

6.0.16348.9381, 13/12/2016

Well it’s not an issue since my files stay the same. It wasnt’t happening with the previous WIP so maybe with the bext WIP it solved itself, I’ll keep paying attention to it.


(Steve Baer) #11

Does this happen with all files? If you start Rhino and just create a file with a single line, do you get the crash with that single line file?


#12

For the last ~3 WIP’s, sometimes after opening or importing a file and closing Rhino, a 0 byte RhinoCrashDump.dmp appears on my Desktop, and Rhino.exe keeps running at its full CPU thread. Since it doesn’t end on its own, I’ll End Process it in Task Manager.

This is 6.0.16348.9381, 12/13/16 on Windows 7 SP1.


#13

It doesn’t happen with all files. I just tried drawing a single line, saving it on my desktop and after closing rhino I got the crash with the single line file. I didn’t have any other rhino windows or versions open.
I also got a mcneel error report window so I’ve send the file in.


(Steve Baer) #14

@tim or @brian is there a good way to track down this specific crash report?


(Tim Hemmelman) #15

If the .dmp file is 0 bytes I’m not sure how we’d figure it out. Siemen, do you get the dialog asking to send in the crash report to Rhino or just the Microsoft crash reporting stuff? If you do get the Rhino dialog, have you sent any crash reports in? What email did you use? That might help us track it down.


Rhino.exe won't quit after exiting WIP
#16

Sometimes it asks me to send in the crash report, but I’ve noticed it’s not always. I’ve send the crash reports in two times I think. One time without e-mail address. I’ll send my e-mail address in a message to you.


#17

@tim,

i’ve sent at least one time a related report. On my side the crash happened when rhino was closed without ever opening a file. (despite from the template which is opened automatically).

I also got this crash at least once when i opened the WIP and the “update available” button was clicked (this closes rhino). In the latter case, the update did not start and the error reporting dialog was shown.

c.


#18

Just experienced a case where the crash did become a problem. I made something in Grasshopper and closed the window but forgot to save. I then closed Rhino after saving the Rhino file and usually there’s a window popping up saying you forgot to save your grasshopper definitions. So that window popped up and immediately changed into the crash window so I couldn’t save my grasshopper work anymore.

Anyway, I don’t expect anybody working on this with during the coming days, with Christmas coming up. So Merry Christmas to y’all.


6.0.16355.12241 Crashing/ Freezing?
#19

I just installed the latest version of WIP and had the same thing happening. Sorry guys.

No crash report this time though.


#20

@siemen,

the source for this crash has been found at it is worked on a solution. Maybe @tim can shed some light what exactly can be done to prevent the crash at least for the moment.

c.


#21

Great to hear! I don’t necessarily need a way to prevent the crash, just wanted to make sure you guys were aware of it so you could find the problem/solution.