6.0.16355.12241 Crashing/ Freezing?


#1

When I’m selecting objects, Rhino gets sort of stuck in a loop and only shows that little popup menu letting me choose objects. It lets me cancel, but no matter what command I enter, it gets stuck in the same popup menu. I’m still able to save, luckily. When I reopen it, it starts working again. I tried to hide a layer before I saved and restarted, and though it didn’t show before, it did when I reopened the file.
Also, the same sort of thing happened with the viewports. They froze and I couldn’t switch from top to anything else. Eventually, they like white-d out. I can still pan.
I’m using Rhino 6.0.16355.12241 on Windows 10.


(David Cockey) #2

What does the popup menu say?

What command have you entered?

How many objects?


#3

I also have problems with this version.
When I shutdown there is a crashdump-file, sometimes it’s empty and another time it could be 36Mb. I also must kill Rhino in the taskmanager.
There are also problems with the panels, the options for the sidepanels is not working.


#4

Hmm, I haven’t needed to kill it in task manager. I even had another window
of rhino open for reference and it didn’t have issues at the same time as
the one that crashed.


#5

I found another thread with the same problems.

I have now sent crash dumps to tech@mcneel.com which not are 0 bytes.


(Pascal Golay) #6

Hi k11 - so, I take it you cannot select an object from the selection menu when Rhino is in this state, is that correct? Can you interact with the menu at all?

-Pascal


#7

I’ve tested the new version rhino_en-us_6.0.16362.06421.exe and the problems are still there.


#8

@pascal- no, I can’t select any of the objects from the selection menu. It
just sort of popped up by itself and then anything I clicked just caused it
to keep popping up. Even after pressing esc, the next thing I clicked made
the selection menu come back.


(Pascal Golay) #9

@k11, what sort of mouse or input are you using, standard 3-button mouse, or something else?

-Pascal


#10

@pascal, Yeah, I’m using a standard 3 button mouse


(Pascal Golay) #11

OK, thanks - I’ll load that exact build tomorrow and see if I can reproduce it - meantime, can you please try opening the WIP in Safe Mode (Windows Start menu, start typing ‘Rhino’ and you should see ‘Rhino WIP in Safe Mode’. Does that behave differently?

-Pascal


(Pascal Golay) #12

@k11, @permalare -can you please give me a blow by blow, for dummies, starting from a fresh instance of Rhino? I understand it ‘just happens’ on your systems, but I cannot reproduce it so far… If you open Rhino, make a box and select it, is that enough to kick this thing off or does there actually need to be multiple possible selections on the mouse-down? What is the display mode, and does that make any difference?

thanks,

-Pascal


#13

I doesn’t matter what I do, there are no differences.
When I start a new instance without loading any file and then close Rhino with the “red cross” there will be a crash dump file which can’t be deleted until I kill Rhino in the task manager. And whatever I do, draw a box or load a file the same thing happens when I close Rhino. And the “options gears” at the sidebar does not function, only the one at the top bar functions.
These things started to happen with the last two versions. Before that everything was OK.
Can you read out anything from the dump files I have sent to tech@mcneel.com?


#14

I tested in safe mode and then there is no crash dump file, but the options buttons does still not work.


#15

I can’t reproduce it on mine, in safe mode or not in safe mode, but I’m done with what I was doing so I’m not quite sure what exactly it was. I tried drawing some things and selecting objects in the file that froze last time, but I couldn’t get it to freeze again. There were multiple objects and the little popup let me choose. I think that’s where the problem was.