Couple of UI things


#1

Any reason why the Properties panel can’t display the viewport properties when nothing is selected (like Win Rhino does?).

In the Display modes panel, I see the setting for turning shadows on or off but it’s not accessible (grayed out). Why?

Thanks, --Mitch


Rhino 5 for Mac WIP Build 5E92w
(Dan Belcher) #2

I don’t think there’s any reason not to show the viewport properties…I’ve logged this one in MR-1993…which relates to a number of other inspector-related refinements (MR-1053, MR-1054) we should make.


(Dan Belcher) #3

Are you talking about this Display Modes panel?

The Shadows checkbox will only be enabled if the Display Mode’s settings have enabled Shadows (Properties > Display Modes > Shadows > …)
…but perhaps I should be reading a nuance into your observation that I’m not :wink:


#4

Yes. That setting (on/off) should be accessible as it is in Windows for the various display modes from the panel… Shouldn’t have to drill down into Preferences (not Properties, this is not Windows :wink:) > Display Modes > ModeName > Shadows to set it on or off.

Thanks, --Mitch


(Dan Belcher) #5

That setting (on/off) should be accessible as it is in Windows for the various display modes

Sorry, now I think I’m really confused. If Shaded Viewports have shadows disabled; and if (for the sake of discussion) the viewport in question has a tick-box for Shadows that can be enabled/disabled, would you expect it to enabled/disable all Shaded viewports, or just this shaded viewport?

Whoops! Good catch…I don’t know how that got typed :stuck_out_tongue_winking_eye:


#6

Well, in Windows Rhino anyway, each display mode has a unique name - you can’t have two with the same name. Doesn’t matter if it’s based on shaded, rendered, technical or whatever… I assumed that the display panel in Mac Rhino showed the currently set display mode NAME in the active viewport - as does Windows Rhino - is that not the case?

If so, I expect the panel setting to behave like the Windows setting does - turn shadows on or off for the particular named display mode that is current in the active viewport.

–Mitch


(Dan Belcher) #7

There seems to be a couple of bugs here…this needs more investigation. I just created a new Custom Rendered display mode from the Standard display mode. I named this “Rendered” (not advisable, I know). I was able to switch to “Rendered” (the custom one) in my active viewport and do enable/disable Shadows from the Display panel (inspector). Ok…sort of weird, but not overly so. Then I deleted the “Rendered” display mode and switched by active viewport back to the Standard Rendered display mode (with shadows disabled). Then I was able to enable/disable shadows from the Display inspector. Catch that last part…?

Then I went back to repeat this bug and I could not. Not a good sign :frowning:

Display modes do not follow the “immutable” Standard template pattern that @marlin (and I, for that matter) prefer. Tweaking a property like enable/disable Shadows should not require creating a copy…hence the Revert to default values option. But there are definitely a couple bugs going on here…I just need to repeat them. Perhaps it’s as simple as your original contention however…


#8

What I want is for the shadows option (checkmark) to be active in the inspector for ALL display modes where it is applicable (i.e. all non-wireframe modes), regardless of whether they are the originally supplied default modes, copies of those modes, modified custom modes, or whatever… I hope that’s clear…

–Mitch


#9

What I seem to be seeing is that for any custom created modes, I cannot change the shadow setting from the inspector panel. --Mitch


(Dan Belcher) #10

Yes, at least that much is clear now.


(Dan Belcher) #11

Yep. Logged in MR-2031.


#12

I agree it can be a wild ride finding functions spread over many places referencing similar functions. I too have had problems with shadow being in multiple places so not at first obvious what does what.


(Dan Belcher) #13

This issue should be fixed in the latest RhinoWIP (5E92w). Please give it a try.


#14

cool!

(i suppose to a Windows user, the issue has been fixed… but for me, it’s a new feature :wink: )