Viewport shaded settings problem [Solved]

Hi I have somehow done something to my viewport shade settings. because now its all low polygon. And i can’t figure out what has changed.

Its the same computer and Rhino version that worked fine a cupel of days ago. so im pretty sure its a setting thing.

[Solution / Problem] The problem was FlatShade and a bug in my program.

Bug is that I can turn FlatShade on and off using the “text command” but only using the text format. and it will not show that its on in General settings or local viewport display mode.
And clicking it on and off under these menus don’t change it status only the text command will.

(“Preferences > Display Modes to the default settings” Did turn it off, but if turned on with text command again, it will still not show as on in local viewport display mode.)

I have don and fresh install and update of Rhino. And now the bug is gone. I can turn on and off FlatShade in text command and it is now correctly shown under local viewport display mode.

Thanks for the help to all that came with input :slight_smile:

Did you check your Mesh settings under file and then Settings?


Thanks for the suggestion, I have checked that an it is set correct :confused:

I don’t know if it has something to do with FlatShade or NoSmoothing. But i can’t figure out how to get to the settings.

Well it was flatShade, for some reason it would not toggle it on and off before Rhino was restarted.

Either you have FlatShade turned on in one of your viewports - under the Viewport title menu, or the View menu

(this is Windows, but Mac should be similar)

– or you have somehow set that permanently in one or more of your display modes - Preferences>Display modes

(again Windows, but Mac should be similar)

This setting should also be accessible from the Display panel in the right sidebar in MacRhino - I think, if my memory serves me correctly.

Hi Helvetosaur, thanks for the input it is FlatShade that caused it.

I don’t know if this is a bug or just me not understanding the difference!
But if i toggle FlatShare on and off using the “text” format the the check box does not changes its shoes it as off.

Well, under General settings in the right sidebar, you are setting the characteristics for the display mode. However, that can be overridden by a local viewport display mode - if you right click on the blue “Perspective” viewport title in the upper left, you will see a menu drop down, does it have “FlatShade” checked?

FlatShade is not mentioned in that menu. (can be a Win, Mac difference)

Looks like it… Do you see the same menu if you click on the main (title bar) View menu, or are there more items in it? BTW, what version of MacRhino is this?

interesting, it is mentioned here

Version 6 (6.31.20315.17002, 2020-11-10)

And yes it is in the main menu. Strange why it is removed from the local window, to me it makes sense to have it there.

OK, but doesn’t seem to explain why you are seeing a flat shaded object when the setting is not active in either the local viewport menu or the display mode general settings… maybe a bug I guess.

@Rasmus Try resetting your Shaded display mode in Preferences > Display Modes to the default settings. Does that help? What you’ve shown is indeed a flat shaded render mesh of a NURBS sphere.

Hi Brian thanks for the suggestion. it dit reset FlatShade but not fix the problem completly.

I have updated the frist post with and Problem and Solution so that people don’t have to read the whole thread :slight_smile: