Properties panel - Display modes

Hi Using R8 latest version.

I am probably being stupid but…

The display mode dropdown in the properties panel doesn’t appear to change the actual display mode in layout ,Am i using this correctly?
so i have to double click the viewport and change it from the dropdown as usual in V7 etc.
I have trawled through the docs and cannot work out why this isn’t working.

Thanks in advance

Hi -

This seems to work as expected here.
2024-06-07 - DisplayMode

Are you doing something differently?
-wim

I am in layout,Sorry didn’t mention that

Hi -

In that case, I’ll need more information. Can you post a picture and your Rhino SystemInfo?
On my end, there isn’t such drop-down in the Properties panel…
-wim

I am assuming i am not using it correctly
I guess it’s just to change the overall page display mode not an indiviual detail view

Rhino 8 SR7 2024-5-17 (Rhino 8, 8.7.24138.15431, Git hash:master @ 03702f889bdef32626af4bca510b5e8a85666d38)
License type: Commercial, build 2024-05-17
License details: Cloud Zoo

Windows 11 (10.0.22000 SR0.0) or greater (Physical RAM: 32GB)
.NET 7.0.20

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3070 (NVidia) Memory: 8GB, Driver date: 4-11-2024 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 552.22
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0
- Windows Main Display attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-11-2024
Driver Version: 31.0.15.5222
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 8\Plug-ins\Commands.rhp “Commands” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 8\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 8\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 8\Plug-ins\SectionTools.rhp “SectionTools”
C:\Program Files\Rhino 8\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 8\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8\Plug-ins\MeshCommands.rhp “MeshCommands” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8\Plug-ins\BlockEdit.rhp “BlockEdit” 8.7.24138.15431
C:\Program Files\Rhino 8\Plug-ins\Displacement.rhp “Displacement”

Ha - the missing part is that you are setting a display mode on an object and not a viewport. But, no. Doing that from the Properties panel is the same as using the SetObjectDisplayMode command. Display modes don’t have exposed settings to alter the appearance of a Detail object, and, so, changing the display mode shows that object in the same was as in the previous display mode.

If you create any other type of object on the layout, you’ll see that this attribute in the Properties panel works as expected:
2024-06-07 - DisplayMode_on_Layout

I suppose that, when activating a detail on a layout, the Properties panel could also have the drop-down that is available in model space:
image

RH-82456 Properties: Provide Display Mode Access to Details
-wim

Cool,Yes,I just worked out it was using setobjectdisplaymode.

Thanks