Display/Other problems with Properties panel?

Again, new user here. But there appears to be a problem with the Properties panel in that some objects are not clickable, some Field Names disappear, and some edit boxes to not reset. This is the first time I’ve played with this panel.

In the sample below, I have a Patch island selected and wanted to turn off Cast shadows. I find that I clicking on the checkbox does nothing. Neither do several other options like Receives shadows, Match, Details. Clicking on Print Color does nothing but make that label disappear and display an Edit button. Clicking on the Edit button brings back the Print Color label text, but nothing else. So lots of odd stuff going on.

System is Dell Intel Xeon W3550 3.0GHz, 6GB RAM, ATI FirePro V4800 (Fire GL V), Windows 7 Pro 64-bit, Rhino (demo) v 5.12.50810.13095

Thanks for the feedback,

Hi John - what does the command History (F2) say above the line ‘A layout must be active etc’ ?



That command sequence is long since gone. But it appears that this panel does not work for anything I select, nor does it seem to work correctly with nothing selected (when only Layout and Layout Settings are present).

Very odd behavior for a core function.


Of course. I thought perhaps you could reproduce the problem. I assume you’ve rebooted the machine, right? I guess I’d try that next.


Added info for anyone interested: The other tabs I have open (Layer, Display, and Help) all work perfectly. Also, on the Properties tab, I can choose the top submenus okay (Material, Texture Mapping, etc.) just fine, but none of the options on these submenus work correctly either.

Yeah, I can reproduce it all I want. It simply doesn’t work.

Regarding a reboot, ironically I came in this morning to a fresh boot, but will try it again right now.


Okay, problem is further narrowed. Closed Rhino, then restarted just the program. Panel works fine. Opened up an AutoCAD LT drawing and the panel dies.

This is happening whether I save it with the default ACLT 2013 settings, or if I save it as an older (2000) AutoCAD/AutoCAD LT .DWG file or as a 2000 .DXF file. So pretty much everything.

If I open up a raw .DXF file generated by my data collector, the panel is fine.

If it’s that file-specific, it would really help if you could upload that file.

Okay, took a lot of playing around, but I think I’ve figured out both how to reliably recreate and fix the issue.

The attached file contains two CAD points and a partial title block. This was saved from AutoCAD LT 2014. I have two ‘layouts’ in that program named Model and TitleBlock. When I import this very basic DWG file, I use the default settings (first three boxes checked, Automatic mesh). Once imported, a new viewport is created in Rhino called TitleBlock.

The attached file is an immediate save after this import. If you open it and don’t select anything, on your Properties panel, you can modify any settings you want. But select any object, then try changing its Properties and you get the misbehavior.

And finally the kicker: Choose the TitleBlock viewport tab, then immediately switch back to the Top viewport. That’s all you have to do to fix the Properties panel.

Kind of obscure? Took me some time to narrow it down at least this far.

TwoPoints2.3dm (318.6 KB)

Hi John - just out of curiosity, if in LT you name the one layout something other than ‘Model’ and go through the same process, does it behave any differently?


Hi Pascal,

ACLT doesn’t let me rename the Model tab as it’s the default workspace and, well, that’s just how it is. I did rename the TitleBlock tab to TitleBlock2 and re-imported that file. It creates a viewport called TitleBlock2 in Rhino and the behavior remains the same.

It’s almost like Rhino is having trouble understanding what ACLT does and is forcing something. In ACLT, the Model layout is where I work with points directly. I then create a new layout which is essentially a ‘paper space’ or print layout if you will. I name this TitleBlock. Then I import my company title block and fill in attributes. I then draw rectangular ‘viewports’ within the title block and set them to show the points/lines at a specific scale.

When I import this DWG into Rhino, it displays the company title block out in the main viewports (Top, Right, etc.) rather than in the TitleBlock2 viewport. In the newly created TitleBlock2 viewport, it looks similar to the ACLT TitleBlock layout with the paper dimensions, grayed area, dashed line, etc, but only a couple of text fields from the company title block are on in this viewport (That could be a problem with my original title block and is not a real concern right now.)

I have yet to explore print layouts in Rhino, so it could be comprehending things absolutely correctly. Just haven’t gotten there yet.


OK - it was s shot in the dark - you said above that there were two ‘layouts’ in LT so I thought maybe Rhino was looking for the word ‘Model’ and was getting confused because it is a layout and not model space, but I guess not…



I’ve got the same bug. I managed how to fix it by going to any Layout Tab and switch back afterwards.