Rhino 7 Copy/Cut/Paste Error - Error accessing the clipboard

Hi!

I’ve just started experiencing an error I’ve never seen before, mentioned in the title. It only affects a single file. It wont allow me to copy anything within that working file, doesn’t matter if its a curve, surface, mesh etc. However, copying and pasting works fine in all other workfiles on the same PC. So the error is directly affecting this single workfile. Down below you can see the systeminfo:

Rhino 7 SR22 2022-9-12 (Rhino 7, 7.22.22255.05001, Git hash:master @ 196b1bc7dd093321e28dcc7a2bb8709a9bebe12d)
License type: Educational, build 2022-09-12
License details: Cloud Zoo

Windows 10 (10.0.19043 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 2-3-2022 (M-D-Y). OpenGL Ver: 4.6.0 - Build 30.0.101.1340
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display attached to adapter port #0

Secondary graphics devices.
NVIDIA GeForce GTX 1080 (NVidia) Memory: 8GB, Driver date: 6-23-2022 (M-D-Y).
> Accelerated graphics device with 4 adapter port(s)
- Secondary monitor attached to adapter port #0

ATTENTION:
Desktop is using the slower, less reliable integrated graphics device and probably needs a configuration change.

An accelerated graphics device exists and is attached to a monitor, but it’s not being used by Rhino.

  • Recommended: Use Windows’ Display Settings to configure the monitor attached to the NVIDIA GeForce GTX 1080, to be the “Main Display”.
  • Any hardware configuration or cabling changes you make will require that you restart Rhino.

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel
Render version: 4.6
Shading Language: 4.60 - Build 30.0.101.1340
Driver Date: 2-3-2022
Driver Version: 30.0.101.1340
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”
C:\Program Files\Common Files\McNeel\Rhinoceros\7.0\Plug-ins\Lumion LiveSync for Rhino (839d6175-32d1-4ffe-a0a4-b7fb43cf0ff5)\2021.3.25.899\Lumion\Rhino 7.0\LumionPlugin.rhp “Lumion LiveSync for Rhino”
C:\Program Files\Rhino 7\Plug-ins\Tibidabo\Tibidabo.rhp “Tibidabo”
C:\Users\Samuel Höljman\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\IntelDenoiser\0.6.4\IntelDenoiser.Windows.rhp “IntelDenoiser.Windows” 0.6.4.0
C:\Users\Samuel Höljman\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\NVIDIADenoiser\0.4.3\NVIDIADenoiser.Windows.rhp “NVIDIADenoiser.Windows” 0.4.3.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.22.22255.5001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.22.22255.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.22.22255.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.22.22255.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.22.22255.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Samuel Höljman\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

I can’t include the file itself as it’s over 800 mb big. Would deeply appreciate any help as I’ve put a ton of work into this file and I’d hate to lose it.

Thanks in advance!

Update: I tried exporting different objects from the file and the problem remains even in the new file. I’ll include one if these exports:
curves for new circle.3dm (153.7 KB)

Hej Samuel -

That file is behaving normally here.
I’d reboot the PC to see if that fixes the issue.
If that doesn’t do it, please try to disable the 3rd party plug-ins and restart Rhino.

As a side note: you’ll want to check the GPU configuration on your PC. As it is now, you are using the onboard Intel GPU whereas you’ll want to use the much more powerful NVIDIA card.
-wim

Thanks for the reply! Disabling landsdesign fixed the problem! And also thanks for pointing out the GPU, don’t know when that setting changed but fixed that now aswell. Problem resolved!

1 Like

I should mention that my trial license for lands design had ran out and it was running it in viewer mode. In case anyone else gets this problem