Paste is very very slow


#1

I have recently been having trouble with my paste command in Rhino 5. Even copying and pasting a simple rectangle can take up to 15 seconds to complete. I get a (program is not responding) up in the upper file name bar while this is happening.


(Pascal Golay) #2

Hi Brandon- do you have any plug-ins running, ones that do not ship with Rhino?

-Pascal


#3

I have the same problem on my PC here at work (not 15 seconds, but 5 perhaps). Plug-ins: Maxwell (2, not 3 - yet), SimLab 3D PDF exporter…

Philip


#4

This is a bit OT:
But I have had that problem with Outlook, so it can be a OS thing.
I never figured out why, and it only happens now and then, but it becomes very sluggish.
I have reduced the pagefile on my system, and I don’t know if that has anything to do with it.


#5

Also have been having a problem with paste. Have reported it to tech support and they are working on it.


#6

It is strange because if I make a new file and draw a simple rectangle, performing a copy/paste does not take long at all-- fraction of a second. But when I do this on the file I am working on it takes 15 seconds. The file I am having this trouble with now is very simple/ small file — about 35 2d lines. However, the lines were exported from a much larger/very complex 3d model that I was also having this problem with. So somehow the problem exported with the 2d lines. ? Wondering if there is some sort of history/log that went along with this file that is now causing issues every time it is copy/pasted.?


(Pascal Golay) #7

Hi Brandon- please try, on the test file:

! _-SaveAs _SavePluginData=_No _Browse

And save to a new name- then test with objects from that file and see if the problem is still there.

-Pascal


#8

Any possibility that these lines have a linetype associated with them?

–Mitch


#9

I do not know how to ! -SaveAs SavePluginData=No Browse

But I instead tried Save As — small and this eliminated the problem. I also tried Save As – geometry only and that also took care of the problem.


#10

There was no linetype associated with them.


#11

OK, just a shot in the dark… So, looks like the objects have some plug-in goo attached to them.

–Mitch


#12

Hi @pascal
I tried -saveas with saveplugindata+no and it made no difference.

Paste takes about 30 seconds for me.