Contour Curve problem!

When I try to create a section curve along a surface I get more curves opened and not closed , in random way without logic. I don’t understand why? I use _CONTOUR command with 0.005mm of step.Lettera S o 5.3dm (94.9 KB)

Hi @ftiozzo_sisma

Your S is an open polysurface (no top and bottom), so I fail to see how you would get anything but open curves. Use Cap command to make a closed polysurface, and Section will give you closed curves. Other than that, if you are creating sections at 0.005mm steps, you should probably tighten your tolerances (currently at 0.001mm), as you are working quite close to the tolerance limit.

HTH, Jakob

Hi Normand
thank you for quick reply, but I tired with different values in absolute tolerance between 0.1 and 0.000005 but nothing happens.
Now the polysurface is closed.
Other things to do ?

I’m guessing you want horizontal sections.

If you recreate the object, it will work - this is the same issue as in that other thread. You will have to find a way to create clean curves from your input.
Lettera S o 5-wrmd.3dm (146.6 KB)

This is the same problem as you posted before in another thread - the letter is composed of a single surface with 3 stacked control points at all of the corners. Rhino does not like these types of structures. Its also very hard to fix automatically, since DivideAlongCreases does not appear to work in this type of situation, and extracting the borders still produces bad curves.

The only thing that works is to rebuild the surface with degree 1 in each direction, THEN use DivideAlongCreases (produces a bad object, you can ignore it in this case), then extract a border, SimplifyCrv on the border and re-extrude the object using the new curve. Then Contour will work perfectly.


How you have recreate the object? Which command?

Yes, is the same problem but I have a problem with section not with stacked points (in this drawing I not have nurbs with stacked points)

I used a polyline to manually trace one of the borders.
The steps are in the file - chronologically from top to bottom.

Yes, the points are still stacked.
The image shows 3 points selected where it should only be one:

I’m sorry but I’m probably not clear.
I have a solid (from customer) and I need to create section (normally every 0.005mm) and after every slice will be hatched (filled). But the section curve are not created in some circumstances (for me not clear why).

Here is one way - as described in my post above. In this case simply tracing the bottom border might be easier, but this method should also work if the border is more complex and would take a long time to trace.


The solid from the customer is bad. With a correct solid - one that does not have stacked control points - creating contour sections should not be a problem.


Thank you Helvetosaur,
If I have a correct solid , all the process for us is good. But in this particular case is possible to correct or not?
Is necessary to recreate the solid?

I don’t see any way to automatically fix the “bad” solids for the moment. The best way would be to allow DivideAlongCreases to split the surface at stacked control points, but that currently isn’t possible. The paradox is that Rhino allows stacked control points, but a lot of operations fail with objects that have them (@pascal this really needs to be adressed).

So I am afraid you will have to re-make them. If they are all composed of straight sides (polylines in plan view) then changing their degree to 1 in both directions will make something you can fix or extract correct edges from. That’s currently the only way I see to eliminate the stacked points.


In my case the 'contour ’ command don’t create closed curve but in random way left open in some points [not always the same] (i’m starting from extrusion).

. I think is’nt a problem with stacked points otherwise i cannot obtain a random result or I mistake?

Can you post a part that does not have stacked control points that shows this problem?


Lettera S o 5.3dm (263.8 KB)
In this example I create a surface and create two section (_Intersect command). In the first one he create a closed curve, on second one he create two open curves. Why ?
The solid is done by extrusion on Z axis…and must be the same section …

If you duplicate the edge of the surface where the section is missing and turn on points. Then select the point as in the attached picture. You are still getting 3 stacked points. (same, of course, if you turn on the points on the surface itself).

Yep, you were faster than me… --Mitch

I’m sorry, why create two curves instead one?
The section plane is only 0.05mm deeper and the solid is done by extrusion (same curve along Z)

Here is your polysurface fixed. I exploded it, changed the degree to 1 in both directions and rejoined the surfaces to make one closed polysurface. Sections/intersections work OK. I would run SimplifyCrv on them afterwards. --Mitch

ZLetterFixed.3dm (220.0 KB)