Contour failing

Hi guys,

My contour command is no longer functioning properly. It was working fine for rebuilt surfaces with moved points to create a wavy polysurface for an architecture course the other day. However today for a different class I made a mountain-like surface with that technique and boolean differenced it with a flat shape. When I tried to contour the surface it said it was “calculating contours” so I waited, and nothing happened it just kept “calculating” for like eternity. When I tried to contour even a simple polysurface after that on a new empty file it did the same thing… In order to escape the command or the “calculating” I have to hit ESC an exorbitant amount of times which crashes rhino (it won’t escape by hitting it once) or end rhino in task manager. I have restarted my computer, opened new files, and even re-installed rhino and nothing has changed. Please help.

I have the same problem. I would also be very happy about any kind of help.

Please post a .3dm file with an example of the geometry which is causing the problem. You can use the Export command to create a file with just the object or objects which cause the problem. To upload the file drag it into where you type a post, or click on the vertical arrow icon above where you type a post.

Also run the Rhino command SystemInfo and post the results.

Without an example of the geometry which causes the problem it is very difficult or impossible to determine the cause and a solution.


in my case it happens with every geometry or file. Even a simple box.


Rhino 7 SR12 2021-11-9 (Rhino 7, 7.12.21313.06341, Git hash:master @ 5590153808223b57a9f41516a969fd949aa81bff)
License type: Lab-Lizenz, build 2021-11-09
License details: Cloud Zoo

Windows 10.0.19043 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 3060 (NVidia) Memory: 12GB, Driver date: 10-26-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.47
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 10-26-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 12 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.12.21313.6341
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”
C:\Users\Lara7\AppData\Roaming\McNeel\Rhinoceros\packages\7.0\PanelingTools\2021.3.2.446\PanelingTools.rhp “PanelingTools”

it says “calculating contours” all the time until I end it via task manager.

Have you tried disabling the V-Ray plug-in?

BTW, how are you accessing your “Lab-Lizenz”?

1 Like

Disabling V-Ray actually worked. But I am using V-Ray for years and it never was a problem. Do you know why it is now?

I access my license online. Why?

You need to ask Chaosgroup about that.

Yes mine happens with every geometry as well.

Disabling vray also worked for me. @Helvetosaur how did you know to do that?

When strange things start happening, one of the first suggestions is to disable any non-native plug-ins and see if that stops the bad behavior. And V-Ray seems to be one of the ones most often cited as causing problems.

1 Like

Ah. Makes sense. Thanks!

V-Ray is also causing Intersection to hang: Intersect Hang Bug - #3 by ddxgood