Component plug-in identifier


#1

Is there any way to examine a GH component and see what plug-in it comes from? If not, could that happen? I’d love to be able to right-click on a component and see this information. Ideally I’d like to see it indicated in the double-click menu.

I have many plug-ins installed, adding hundreds of components, and I can’t keep them all in my head, or even always remember which are stock GH and which are add-ons. It gets old scrolling through 6 or 8 menus to find where something came from and maybe still not finding it. It’s handy when authors use names and icon styles to clue this, but not all do, and in any case I can’t remember a dozen different icon styles either.

Why do I need to know this? Some plug-ins have suites of components designed to work together, and in cases where functionality overlaps, e.g. Elefront and Human, it’s not always easy to remember which set I’m using at a given moment. Sometimes a plug-in needs an update and I’m not ready to give up on it, but I don’t want to use any more of it until that arrives. The signature functions of big plug-ins are usually recognizable, but often there’s a grab-bag “Utilities” group with all kinds of unrelated stuff that can be really hard to recognize or track down.

I’d also like to be able to list the dependencies of a GH file, or a group of selected components. Can I uninstall Heteroptera safely? I have no idea.

Sorry if I’m missing the obvious here, this seems like something that maybe already exists and I couldn’t find it.

Thanks if you can help!


(Wim Dekeyser) #2

When you hover over a component and hit Ctrl and Alt, a :information_source: icon will appear next to your mouse pointer. If you then LMB click on the component, the source of this component will be shown. Does that do it?


(Nathan 'jesterKing' Letwory) #3

That tells what category the component comes from - not necessarily what plug-in.


(Wim Dekeyser) #4

I’m not sure what the difference is - maybe I’m not running enough plug-ins?


(Laurent Delrieu) #5

A plugin to list all plugins



#6

That does it. Wack!! I never would have found that.
Thanks.


#7

Thanks, problem solved. Though Yak sounds pretty cool too.