Command + W often crash the RhinoWIP


#1

Hi @dan
Cmd + W often crush Rhino Wip
It seems to happen with most files,

  • one guess I have is that perhaps sleeping with more then one document is somehow connected to this.

this type of crushes happens to me since a long while, and are not specific to the current WIP.

  • I never lost any data and kind of got used to it, accepting crushes as an expected part of working with a WIP,
    but it is quite consistent,
    [I sent the report of today’s one]

it is probably a well known issue but I though it is time to report… just incase.

with thanks
akash


Rhino 5 for Mac WIP Build 5E78w
#2

yep, this has been happening a lot with me as well… (though not necessarily closing the file via cmmd-W… if i close it in other ways, the crashes still happen)


(Dan Belcher) #3

Interesting. Thanks for submitting the automated crash reports! Please keep it up, each time if necessary…the information the report provides us can be very helpful.

I haven’t been able to reproduce this one yet. The one I’m seeing - perhaps related - is on quitting Rhino when no documents are open. But I haven’t been able to reliably reproduce that in a debug session either.

it is probably a well known issue but I though it is time to report… just incase.

Please don’t presume it’s well known. Please keep submitting the automated reports with a comment as to what you were doing when it crashed…and if you can produce reliable steps, well, you know the drill :wink:

Thanks as always. Let’s track this down.


(Dan Belcher) #4

Please test the latest RhinoWIP (5E78w) to see if it’s better (or not).


#5

i just had another of these crashes (didn’t see the update yet).
testing with 5E78w now.


#6

hey Dan…

here’s another similar crash that’s still happening with me on 5E78w…

• open a previously saved .3dm
• draw a line (or, do something to the file to place it in an unsaved state)
• close the file (cmmd-W)
• at the prompt, choose Revert Changes

crash.

(the crash report was sent as well… if you’re unable to reproduce the crash)


(Dan Belcher) #7

Thanks for reporting that Jeff. I just tested in 5E78w and I’m not seeing that crash on my machine. Thanks for submitting the bug report. Hopefully, looking at the crash dump will help. Keep them coming!


(Marlin Prowell) #8

Jeff - what do you have for startup commands when a model opens?


#9

hey @marlin

right now, i only have one:
SetMaximizedViewport Perspective


#10

@marlin @dan

so i did ExportPreferences then ResetPreferences… then relaunch and ImportPreferences

The crash i described is no longer happening after that.


i was hesitant to try this earlier because i have 11 custom display modes and i wasn’t sure if Importing them was working right or not as i haven’t tested it lately… thankfully, those came back upon importing so all is well (for me at least) :thumbsup:


but maybe others who are experience this crash can at least fix it on their end via resetting the preferences.


#11

Good to know, Jeff. Thanks for being brave!


#12

Hi dan
it seems good, I’ve been unable to reproduce the crash since the latest WIP.
thanks a lot.


#13

hey @ec2638

a little more info i found out that may come in helpful down the road…

if you ImportPreferences -> Advanced Display from another mac, the custom display modes will be merged…
or- the modes from mac#1 won’t replace the ones on mac#2… you’ll end up with the display modes from both computers.


(Marlin Prowell) #14

@jeff_hammond Thanks for the detailed description for creating the crash. I was able to find and fix this. The fix will be in the next WIP.

The crash happens when running SetMaximizedViewport in your startup commands during the revert. Don’t know why refreshing your preferences with and Export and Import would fix this, unless it did not restore your startup commands properly.


#15

yep @marlin, that’s what is doing it.

the startup command didn’t come back when importing preferences… when i put the SetMaximizedViewport back in the startup commands, the crashes happen again.


oddly enough, my new models are now opening in a maximized perspective viewport with or without the startup macro which is why i didn’t notice the startup command didn’t sync.
?
(which i how i prefer it… i’m just not sure what’s making new models open in the single viewport instead of 4views… any reasons/ideas about that?)


#16

oh… never mind.
i just figured out how to make the models open in a maximized viewport. (if using custom templates at least)

make the file a template when the viewport(s) is in the state you want it in and that’s how it will be upon New File.
neat


(Dan Belcher) #17

This crash should be fixed in the latest RhinoWIP (5E92w). Please give it a try.


#18

yep, this appears to be fixed in the latest WIP… no longer crashing upon ‘revert changes’ when having SetMaximizedViewport in the startup commands.

:thumbsup: