Color Gradient: How to remove banding?

Hi,

I would like to save images in high quality but notice a slight banding effect appearing on color gradients. I’ve checked the “Dithering” option in the “Render” properties but no visible change can be seen (both with “Floyd-Steinberg” and “noise” mode)

Is it possible to remove that banding, or at least dampen it in Rhino ? (Photoshop isn’t an option)

I do not see anything I would describe as banding in that screenshot.

Any chance you’re running old GPU drivers or more monitors that you have VRAM to support?

I know it’s subtle but I can guarantee there is a banding effect.

I don’t think that’s a monitor issue since I can see it even from my smartphone (when loading the screenshot above). I have a decent GPU (RTX 2080) and all my drivers are updated.

Maybe it is a bit more obvious on this picture ?

Is there a way to enhance the dithering maybe ?

Do you have Flat shade turned on?
image

No. Just tried to turn it on but don’t see any change.

Can you please post a small example file with the specific instructions to follow to see this ‘banding’?

It looks more like a limited display color pallet being applied to individual mesh facets.

Also, run the Rhino SystemInfo command and post those results so we can see what computer resources Rhino is seeing.

Thanks

1 Like

He meant do you have it turned on, turn it off if so.

Are you doing a screen shot or a ‘render’? There would be no dithering options for the screen capture, that would be for rendering.

I can just barely make out the ‘banding,’ short of photoshopping noise in–texturing it with some subtle noise?–I don’t think there’s much you can do. It’s an incredibly subtle variation on brown, there isn’t going to be much of the color space to work with.

What you’re showing in the other shot is something else completely.

1 Like