Display issue: color banding

Hello,
Since recently, the render viewport mode has been showing heavy color banding, like 8 bit images/video.

However I have a top-notch Nvidia Quadro P5000 on my laptop.

What could be the source of this problem?

Hello - my guess of the moment is that is an artifact of the resolution of the light source in that image. Does the banding show in say, a gradient texture directly?

-Pascal

yes it does.

Under display settings (W10) for display 1 (my laptop screen / the one I’m working from now) there’s only the default Intel HD 630 listed, not the Quadro p5000 that is selected inside Rhino. There’s no option to select the P5000.


Could it be that Rhino is using the lower grade Intel graphics card instead of the P5000?

Hello @Arman_Fissette and @pascal, I have the same problem with render view mode… did you fix it?

Thank you!

Hello - please post an example image and please run the SystemInfo command in Rhino and copy/paste the results here.

-Pascal

Hi, Pascal, thank you for your reply so…
this is my shaded view


And this is my render view:

this is my system info:
Rhino 7 SR4 2021-3-8 (Rhino 7, 7.4.21067.13001, Git hash:master @ ed629035202f07e8b84a3ee211479ca20bb81b73)
License type: Commercial, build 2021-03-08
License details: LAN Zoo Network Node

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel® UHD Graphics P630 (Intel) Memory: 1GB, Driver date: 9-11-2020 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro T2000 with Max-Q Design (NVidia) Memory: 4GB, Driver date: 2-23-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.72
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-23-2021
Driver Version: 27.21.14.6172
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.4.21067.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

This is my open GL dialog Box:


I already tried to deactivate the integrated graphic card from the bios and to update both graphic cards, but nothing changes in the rhino render view…

Hello - one thing I notice is that in the rendered view the curved surface of the cylinder is shading across a very limited gray scale and the shaded view uses a much wider band of grays. I can repeat the stepping if I use a medium gray material with no gloss - i.e. ‘Plaster’ but it is less, or none, if the material gets some gloss -

Plaster above, Plastic below:

Since there are only 256 levels available, I guess this is an artifact of that… there are no values in the range that fall between the bands to smooth it all out.

@nathanletwory - does that make sense?

-Pascal

Yes, the viewport I believe is not yet full float buffers. If you need better gradients over a short interval you need to render in the render window.

Hello, I’ve a problem Using Rhino (6 or 7 have the same problem) with my new laptop with 2 Graphic Cards installed.
the first one is an Intel UHD Graphics P630
the second one the NVIDIA Quadro T2000 with Max-Q Design.
In the render view visualization I have a color banding problem.


Do you know how I can solve the problem?
Thank you

Same here - I’m running dual A5000’s and the Perspective viewport in Rendered mode is heavily banded. By contrast, Maya and 3DMax are not.