Closed solid polysurface doesn't show material


I’m having problems seeing materials on my closed solid polysurfaces in Render view. Is there any way you can help me? :slight_smile:

Dear @user2590 - what s your (nick-) name ? (you may want to assign it to your profile ?)
welcome to the forum - please post a file that show s your problem. just drag and drop it to the edit window, make sure the file includes textures

Hi, thank you for the fast response.

Actually I have worked on a project in Archicad, put textures on the file. When I import in to a Rhino file, all the textures are missing. I’ve tried exploding the blocks, but my polysurfaces wont get the material I add in Vray.

Hope you can help me! Here is a small cut out of the project
DRAWING udsnit.3dm (8.8 MB)

/ Lisa

your topic is a export Archicad, import to rhino problem ?
i recommend to check this workflow with a single object and a single material / texture first.
which export - format are you using ?
did you check the Archicad help / support ?
did you google “archicad to rhino import / export with materials / textures” ?
i think i am the wrong person to help, i am not an archicad expert. sorry.

Thank you for your reply.

In archicad I’m saving as a 3dm, I’ve tried dufferent saving options and none seem to help.

I will try to ask the Archicad help support as well.

Thank you!


Dear Lisa

Look s like it s an Achricad-Problem:

“An ARCHICAD model exported to Rhino transfers geometrical information only, because Rhino handles only this type of data.”

Relevant element attributes (surface color, texture) and … are retained.

I see. Is there any easy way you can add textures afterwards in Rhino? When I explode the objects in the file and turn them into polysurfaces, they still don’t seem to get texture that I assort in their layer…

you can assign material per layer
in the layer-palette, there is a square for the layer color, next to it there is a round color-icon for materials.
you can also just drag and drop materials on single objects.
you will find many tutorials online
for example here

Hello, I can’t seem to assign a texture to a polysurface. WHat do I do?

Hi Lisa -
It looks like all objects have materials applied…

That is because the materials are assigned to the individual objects, not the layers.
You could select all objects, and, in the Properties panel, switch to the Material tab and click in the field that now says (Varies):


Then select Use Layer Material:

After that, assign materials to the layers.

Other than that, you could try to export the model in a different file format but I don’t know what features and formats ArchiCAD supports…