Clipping planes and M4000

Hi
I have a problem with object visibility when i use clipping planes.
In wireframe views no curves or edges (wires) are visible inside within the cut area when the clipping plane are active. In shaded view the shade are visible but not the edges or curves.
If i change the “display pipeline assignment” in display options to windows instead of openGL the curves and edges appears. This is not possible in shaded view…
This only happens in my system with a quadro M4000 GPU so I suspect thats the problem.
I have tried to uninstall and install the latest driver without any success.
Anyone have a idea?

Hi - please run the Rhino SystemInfo command and post the result here.
-wim

Rhino 6 SR16 2019-7-9 (Rhino 6, 6.16.19190.07001, Git hash:master @ a8b4ee102e9e0eb1d11825df063e13f96d518f93)
License type: Commercial, build 2019-07-09
License details: Cloud Zoo. In use by: scenografi ()

Windows 7 SP1 (Physical RAM: 32Gb)
Machine name: UNIVERSE3

Non-hybrid graphics.
Primary display and OpenGL: NVIDIA Quadro M4000 (NVidia) Memory: 8GB, Driver date: 7-24-2019 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 431.70

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-24-2019
Driver Version: 26.21.14.3170
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 8 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\AsuniCAD\Bubble 3.0 WIP26\RHINO6\Bubble.rhp “Bubble”
C:\Program Files\Rhino 6\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Users\FredJohn\AppData\Roaming\McNeel\Rhinoceros\6.0\Plug-ins\PanelingTools (6caed836-bc06-4ebc-b1fd-e10886a0dc94)\2018.6.14.669\PanelingTools.rhp “PanelingTools”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.16.19190.7001
C:\Program Files\ADA 3D\Mesh2Surface for Rhino 6\m2s_for_Rhino.rhp “MESH2SURFACE”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.16.19190.7001
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\MPlane.rhp “MPlane”
C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”

Anyone? Wim?

@wim

1 Like

Hi - I’m not seeing anything wrong in that system information.
I see from the screenshot that you have a modified Shaded display mode (and can’t tell which modifications are done to the Wireframe mode) - does it change anything if you reset the display modes to their factory-default settings?
-wim

Hi Wim
Yes I tried to reset to default display modes with no success but when I change the display pipeline assignment to windows instead of openGL (which I guess is the GPU) it works.(but windows cant handle bigger files)

Hi - could you please upload that simple 3dm file and export and upload your Wireframe and Shaded modes that you use to reproduce that behavior.
-wim