Clipping Plane Fills! Please

is it really that difficult to implement such simple funcionality once well and for good ?

I am running to these issues right now too.

Fills only work with basic geometry. Not on geometry within the blocks, which is a bug definately.

1 Like

Make sure the display mode shows fills.

The strange thing here is that I made a custom tool that extracts the clipping data and it appears that the clipping data for many objects are available, just not visible in the view.
@wim do you know who that should be addressed to? It seems like a bug.
And I have also noticed that the clipping data is shown facing the wrong way:

these little bugs then cause that unpleasant biting emotion that the program is not so reliable when you come across them. i am falling in love with rhino and suddenly there is this little stupid thing :frowning: but nothing is perfect in this world … i still think when a function like clipping plane is introduced it should have been already tested so it works flawlessly from day 1

2 Likes

I can only agree with you. That feeling of having something great at your fingertips but not being able to grab it, it’s a sensation I often get with Rhino. Come on McNeel solve these little bugs please. You are really close to have the best 3d tool for designers.

1 Like

Hi, the conversation on this topic is an extremely long one. I have gone through some of them which I think might be what I am searching for. I just need to have a solid black fills on the section cut via clipping plane. Here is a screenshot of my setting

This is the result I got despite the setting to show solid fill in clipping plane objects.

I have also tried section tool plugin but to no avail.

I am not sure what goes wrong here, is it because the object I created is not a closed polysurface? In fact, I do have closed polysurface, as the photo attached below. Yet, they are still showing white solid fill with thicker section cut. I want them to be black instead.

Sincerely appreciate if anyone could help me as this is a great trouble to me.

OP here.

My experiments over the past year suggest that there isn’t a Rhino display mode which can be set to reliably display all three of the following: clipped fills, contours on curving surfaces, and line weights set for clipped objects. If there is, I haven’t found it. The best I can get is a different two of those three on any one of the range of view modes Rhino provides.

“Hidden”, a display mode available with Visualarq (a parametric architectural plug-in I regularly use) is the only mode I feel I can rely on to do those three things at once. (I think I can get it to show intersecting planes reliably, but that’s another source of difficulty I’m not sure I’ve mastered.)

[But Hidden’s only useful for lines. Hidden doesn’t shade, render or texture. I believe Rhino has problems displaying lines with shading in a view because Rhino constructs and displays objects made of planar facets on which to display shading, and these display objects too often severely occlude the linework in most views for the combination to be reliable.

So I double up every detail view, using a Hidden mode view for linework on one layer, on top of a rendered mode view for shading, shadows, and rendered textures. I have separate layers for these two detail views on my project template and use “copy objects to layer” to create the Hidden one once I have the Rendered one the way I like it.

It’s the only solution I’ve found that works. It’s a bit laborious and pitfall-prone but I’ve streamlined it.

(Locking the views is especially crucial to avoid headaches with this two-view setup, but heed this: There’s a bug in the current Rhino. Though group-selected views will be locked after ‘lock’ is checked for them in the properties panel, the check won’t display for them when properties is next open - though they will in fact be locked. Management can get confused.)

(Also - A locked detail view can’t be brought to front or sent to back, they have to be unlocked for that. Don’t forget to lock them again. Separately if you want properties to reliably tell you whether or not they are. Pitfalls.)]

Try setting your HSV values in the clipping plane fill color to 0,0,1, instead of 0,0,0. True black shows as white in Rhino when applied to breps (?).

Anyone know why clipping plane fills are not supported on Grasshopper objects? Works fine on the baked object in Rhino. Is this just a bug, or an unsupported feature?

Clipping plane fills are inconsistent in all my testing with Rhino View Modes no matter what colour it’s set to.

Going to add another issue here that is related. The texture fill setting of the clipping plane seems to ignore the origin point of box mapped elements within a block! This behavior can be clearly seen in the examples within this different thread. Box mapping different in a block.

However, you can see that we managed to do proper hatching for our rhino geometry. We used the texture fill functionality of the clipping in combination with proper boxmapping to get the correct insulation hatches. This functionality works quite well except that within a block this performance sadly changes.
image

Please MCneel make this happen <3

Hi -

I’ve added your vote to RH-53061.
-wim

2 Likes

For an example of the implementation of this feature, please see Visual Arq’s Section Properties panel, which unfortunately only works in one display mode (Va’s “Hidden” mode.)

And to be fair this must be added: Visual Arq’s Clipping Plane can drop your viewport’s fps 3 times.
So if you are ok with working in 15 fps, then yeah, it’s a valid option.

So that’s slowing things down sometimes. Good to know, thanks. In any case I was referring to the UI aspect.

For any clipping plane fills to work properly you have to make sure that the object you are using the clipping plane on is a water tight joined brep with no naked edges or micro edge loops.

Even if those conditions are met, I believe its been discovered through much exploration that successful clipped fills is inconsistent (I would say it usually fails) , with the exception of clipping of VaSections in Va’s Hidden display mode.

The latest I am discovering on this, with Rhino 7, is that there is still no one display mode which will display all of 1) materials, 2) shadows, 3) clipped fills, and 4) silhouettes on all surface contours including curving ones. I have to use two layers: Bottom Layer is Rendered - which gives me 1), 2) and maybe 3). Top Layer is VisualArq’s HIdden Mode which provides 3)(always reliably) and 4), and adds the ability to set the border thickness of the clipped fill by object. 3) may be reliable now in Rendered for me - haven’t tested it enough yet, but currently the absence of 4) in Rendered mode is the killer.

1 Like