ClippingPlane anomaly?


#1

in the “clippingPlane” settings I set solid color (gray color); why Rhino does not respect this setting? (the cut faces have the color of the object I chose).
is it a bug or am I wrong to set something up?


(Pascal Golay) #2

Hi Davide - please post the file and Export your display mode and send that as well, I’ll take a look.

-Pascal


#3

Thanks Pascal,
the file before was just a test, sending another like that (in shaded mode).
clipping plane defect.3dm (125.5 KB)


(Wim Dekeyser) #4

When I open that file it looks like this in Shaded mode:

It’s obvious that you have changed the factory-default display mode settings and that is why Pascal asked you to also export your display mode as an INI file…

If you reset your settings to the defaults, is it showing the correct color then?


#5

Wim, could you explain how to export the INI format display mode? Thanks.
(I’ve changed the default color in the “custom material” tab, and added an Emap in the environment. I did not do it anymore).


(Wim Dekeyser) #6

Rhino Options > View > Display Modes

Select the “Display Modes” in the left pane. This will cause the right pane to show a list of all your display modes. Select the display mode that you need and then click the Export button at the bottom.

If your Emap is a picture, you will also have to attach that here.


#7

Required files:
Ombreggiata.ini (12.5 KB)
Emap:


(Pascal Golay) #8

I see… I guess the setting for a custom material ‘override object’s color’ counts as overriding the fill color as well - I can maybe see some logic there but it seems incorrect to me. I’ll see if we can fix it - thanks.

https://mcneel.myjetbrains.com/youtrack/issue/RH-41309

-Pascal