Changing keyboard shortcuts

Can anybody tell me how to change the keyboard shortcut in Rhino for Mac? I’m used to using Rhino for Windows and lots of the keyboard shortcuts use the Ctrl key. Generally, with Mac software, the Ctrl key is swapped for the Cmd key, and this is the case with commands like Group (Cmd+G), but for some reason to Hide an object, its Alt+H rather than Cmd+H (which hides Rhino!). Is it possible to customise shortcuts?

It looks to me like not- Aliases, yes, in Preferences, but I do not see anything for shortcuts so far.

shortcuts are at
Rhinoceros -> Commands -> Customize -> Keyboard Shortcuts

that said, i’d be hesitant about using ⌘H for _Hide
while mac rhino will allow you to set that as a custom shortcut… (ie- rhino for mac doesn’t have any real ‘rules’ for shortcuts… anything goes.) , you may run into a conflict since ⌘H is an osx shortcut for hiding applications…

it might work fine though? idk, try it :wink:

That’s the chap, thanks… my Windowsness is hard to overcome, I never would have thought to look there.


with mac, there isn’t really a standard method for assigning custom keystrokes in a particular app… basically, the apple applications don’t have the ability to customize shortcuts within the program so there’s really no guideline to follow… all the software that does have it is custom coded to the developers vision moreorless.

point being, even if you’re a mac person from way back, you wouldn’t necessarily know how to find/set shortcuts in rhino so it’s a good one to have pretty clear info in the manual.

Hi Jeff- thanks - your comment kinda makes me think then, that it ought really to be in Rhinoceros > Preferences (where it belongs!)


yeah. probably right.

Thanks Jeff (sorry for the delayed response!). I did find the route you suggested previously, but I can’t find a way of actually changing the set-up. When you go into Keyboard Shortcuts, I assume you have to make a Duplicate set of shortcuts, then you can edit the one you want. I tried changing the Hide Objects to ⌘H, but it still hides Rhino rather than the object, so I guess, as you suggested, the OsX shortcut overrides the Rhino short-cut…I’ll just have to live with it, unless I changed it to ctrl H instead!
Thanks again for your help.

I basically set up all my shortcuts I use on WIN now in OS X. So far so good - there is now only one that is conflicting with OS X: the hide command. Right now nothing happens. Neither the object hides nor the window …

I recognized Adobe has the same issue (Photoshop). A fresh Photoshop will ask the first time you use CMD+H what to do and then eventually deletes the OS shortcut so it’s a Photoshop-only shortcut.
Can’t you do the same?

To check for system wide conflicts go to system preferences, click on keyboard and select Shortcuts. Most of these not only have re-assignable keyboard commands but also a checkbox to turn them on and off altogether, and I’ve turned almost all of them off so as not to conflict with other applications. At one time the message pump would dispatch key commands first to the application with focus, then to the OS X, but this is no longer always the case, which means if there is a KB command associated with certain portions of the OS (accessibility / spaces / launchpad and various others) they will route to the OS first, THEN to the app with focus meaning the app will never see them if they are assigned.

I tried to reverse my setting - is there any way to edit a KB shortcut command in a text editor? OS X does not let me put in cmd+H for “Hide Application” …

I can’t seem to make any changes… When I pull up the editor the menu shows the active set as “Default (read only)” with no other options available. I’d really like to make a keyboard shortcut for Join 2 Naked edges and Delete Control Point.

Sorry for the late reply. Looks like this issue is the same as the one you brought up in the other thread. This should be working in the latest RhinoWIP when running in El Capitan - as Marlin mentioned.