Can't select spaces by clicking on the tag

While modeling a project all of a sudden I could no longer select spaces by clicking the tag. While trying to diagnose the problem I discovered that I could select them when the view was not maximized, but if I maximized the view I could not long select them. Seems to be some sort of bug, does anyone know how to fix it?

I discovered that it happens when I “Set Plan View to Viewport” under the levels menu. Still not sure why though

Figured it out, it was because I was in hidden view. When I change to shaded or wireframe I am able to select them. Still not sure why I am able to select them when the view is minimized but not maximized, but at least I can continue working now.

Hi @seflorance we had this issue about not being able to select objects in Hidden display mode, reported in the past, and fixed it, but maybe your case is different. Can you send us ( that model and indicate which spaces you can’t select and from where?
Make sure you are using the last VIsualARQ version (2.8.2).

1 Like

Hello Francesc,

I noticed I was not running the latest version of VisualARQ so I updated it, but the problem persists. It is the strangest thing. I am working on two monitors, when I have the Rhino window on the small monitor I am able to select the spaces in hidden view, but when I have it on the big monitor I am not. Even stranger, I noticed that when I make the Rhino window smaller on the big monitor I am able to select the spaces again. It seems that it might have something to do with the size of the screen or resolution or something. I tried to attached the file I am working on, but it said it was too large to send to you, but I don’t think it is specific to this file. Do you need me to try to send it to you some other way?

Thanks for your help,

Hi @seflorance,

Yes, viewport resolution may affect selection on the “Hidden” display mode. This is because hidden display mode filters objects that are not visible, so you can work on a plan view, for example, objects behind a slab are not selected. Also, if you click on the blank area inside the slab, the slab is not selected. You can try to change to “Shaded” display mode, and you’ll see it is complex to work in plan view, as slabs are always selected first when you try to cross select.

In order to implement this, we create an image where pixels are not using the color object, but the display id, so when you click on the viewport, we can find quickly which objects are under the cursor.

I guess you’re using big monitor, probably HiDPI (4K), which means that when the viewport is maximized, the required image is too big, and if there is not enough memory available on the system, the image couldn’t be created.

I’m creating an entry in our bug track system to fix this issue in the next VisualARQ version. If you’re interested: if image couldn’t be created, I’m going to reduce the image size by four (2x2) until success. Selection will be less precise, but in a HiDPI viewport, this won’t be a real issue.



1 Like