Can't grab Gumball scale grips

Every now and then, I have this problem where I cannot grab the gumball scale grips.
It happens at a certain zoom level, no matter what display mode I’m in.

21_07_14_two_breps.3dm (136.4 KB)

System Info

Rhino 7 SR8 2021-7-6 (Rhino 7, 7.8.21187.05001, Git hash:master @ 192a2a48e69da14d2318023b008b0f252e30b7c8)
License type: Kommerziell, build 2021-07-06
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-7-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro P4000 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 4-12-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 466.11
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-12-2021
Driver Version: 27.21.14.6611
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Program Files (x86)\Evolute\EvoluteTools T.MAP for Rhino 6\EvoluteCoutHook.rhp “EvoluteCoutHook”
C:\Users\martinsiegrist\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\1.0.0.0\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin” 1.0.0.0
C:\Users\martinsiegrist\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\Rhino 3DM File Version (aa091cb2-d8c0-4944-a17d-b66c80bec4ca)\7.0.7639.20582\RhinoFileVersion.rhp “Rhino 3DM File Version” 7.0.7639.20582

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.8.21187.5001
C:\Program Files\Rhino 7\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 7\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.8.21187.5001
C:\Program Files\Rhino 7\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.8.21187.5001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.8.21187.5001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.8.21187.5001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi Martin -
A few questions…

  • Is this a new issue for you or has it always been like this?
  • You are running a few non-standard plug-ins - does it happen with those disabled?
  • From the second video, it looks like you are using a 3D input device. Does it happen with a regular mouse?
  • When I select the objects in your file, my gumball looks different than yours. Have you tried resetting the gumball settings to their defaults?

-wim

I have disabled the Evolute plugins but the problem persists.

I’ve been using 3Dconnexion mice and space navigators for years. I don’t think it is a new problem but unfortunately can’t tell you for how long this caused problems. In Rhino 5 it wasn’t a problem for sure. I also just tested the new file in this post with Rhino 5 and it works fine.

I did reset the gumball but it doesn’t change a thing.

Here’s the same file from above, now with a named view:

21_07_14_two_breps.3dm (147.8 KB)

and a Rhino 5 file also with a named view:

21_07_14_two_breps_5.3dm (182.1 KB)

My gumball settings:

I can confirm it, at high zoom level grip not touchable.
What works: At lower zoom level, press CTRL, move grip towards gumball, zoom in and scale.
But is only temporary, next time you select one object grip is again far away from the gumball.

Looks like in RH7 we have dual trouble with “Object to far from original and Grip to far from gumball original”
:disappointed_relieved:

1 Like

Not quite a high zoom level.

I’m zooming one step with the scroll wheel and then try to grab the scale grip. First zoom in succesful, second zoom in fail… back one step and succes again

Sorry for my bad Enu-language,
I’m mean: At lower zoom level, press CTRL and hold down, move grip towards gumball, release CTRL, zoom in and scale.
Grip

Got it… and at some point also that fails

The closer the grip is to gumball, so higher the zoom factor can be

I reset my Gumball settings to default but no success with the grab problem.

When I zoom or rotate a view, at some point the scale grip can’t be grabbed anymore.

I prefer having slightly bigger scale handles on my 4K screen

I had also reported this anomaly, about a month ago … Nobody listened to me… :man_facepalming:

1 Like

Bug Gumball (scaling operation) - Rhino / Rhino for Windows - McNeel Forum

Are you using 3dconnexion devices?

1 Like

Wim, interesting. After reading this topic, I remembered I had a gumball issue on my old workstation.

Now, new machine and no gumball problem. So for now this is solved.