Gumball scaling handle not pickable

Lately I’ve noticed that I cannot select the gumball scale handle if it’s close to the edge of a viewport. In the attached example, I cannot select the red scaling handle. When I try other things, I see that it might not be proximity to the edge of the viewport, but it has to do with scale & location of the object.

gumball bug.3dm (199.7 KB)

1 Like

Fwiw, I’m using my old laptop while my new one is in the shop - here is the system info:

Rhino 7 SR6 2021-5-7 (Rhino 7, 7.6.21127.19001, Git hash:master @ aec74c050f3ca28ab3cfd6882e9453a52366a9b7)
License type: Commercial, build 2021-05-07
License details: Cloud Zoo

Windows 10.0.19041 SR0.0 or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [96% battery remaining]

Non-hybrid graphics configuration.
Primary display and OpenGL: NVIDIA Quadro K3100M (NVidia) Memory: 4GB, Driver date: 5-29-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 426.78
> Integrated accelerated graphics device with 4 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port

Secondary graphics devices.
Intel(R) HD Graphics 4600 (Intel) Memory: 1GB, Driver date: 9-29-2016 (M-D-Y).
> Integrated graphics device with 0 adapter port(s)
- There are no monitors attached to this device. Laptop lid is probably closed

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 5-29-2020
Driver Version: 25.21.14.2678
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Bongo 2.0 (64-bit)\Rhino6\Bongo.20.rhp “Bongo 2.0”
C:\Program Files\SimLab\Plugins\SimLab 3D PDF From Rhino 6\plugins\SimLabPDFExporter.rhp “SimLab PDF Exporter”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino WIP\Plug-ins\Commands.rhp “Commands” 7.6.21127.19001
C:\Program Files\Rhino WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino WIP\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino WIP\Plug-ins\RPC.rhp “RPC”
C:\Program Files\Rhino WIP\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino WIP\Plug-ins\AnimationTools.rhp “AnimationTools”
C:\Program Files\Rhino WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.6.21127.19001
C:\Program Files\Rhino WIP\Plug-ins\RhinoRender.rhp “Legacy Rhino Render”
C:\Program Files\Rhino WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.6.21127.19001
C:\Program Files\Rhino WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.6.21127.19001
C:\Program Files\Rhino WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.6.21127.19001
C:\Program Files\Rhino WIP\Plug-ins\Displacement.rhp “Displacement”

You can see in this video that the handle isn’t selectable when I’m zoomed in but is selectable when I zoom out.

Hi Peter - I do not get this happening here so far in our latest; it may be useless in this context but since it is likely a display thing and I see your Intel driver is quite old, I would see if there is a later one available from the Intel website, just to eliminate that variable. Likewise, try blocking Bongo in Options > Plug-ins page, and restarting Rhino to see if that makes any difference.

-Pascal

Yeah, I can’t find a better driver for this card and disabling Bongo doesn’t help. I’ll check it on my newer laptop when I get it back & see.