Can't detach attached model


-I have attached a model
-I wanted to extract mesh faces from the mesh inside of the attached model
-Resulting faces did not copy to current layer but inside of a layer which is part of the attached model

The problem is now i cant even detach the model. nothing happens when i detach it.
I tried to attach the same model again. Two were present at the same time but it didnot help.

cesta_model.3dm (100.4 KB)

i cant see anything wrong with what you have posted. no duplicate faces nothing overlapping, can you try to explain your problem a bit different?

Try to open new rhino and attach that file a try to run extract mesh face on selected mesh faces from the attached model. Then you should see strange things.

i see them, which might be some display mesh artefact, but it extracts actually all the faces

and try to detach the model now.

sorry but i am not sure what you mean by detach, attach the file here?

i extracted those faces

and got this result

Bildschirmfoto 2022-01-19 um 14.53.27

are you referring to issues with the layers after all? to be honest i also use a mac, maybe i am not seeing the issues you have…

yes clicking on the “layer” which is basically a file right click and detach, thats not working after extracting the faces. It probably wont be the same on Mac

it happens also with copy, when i copy some object from the attached file it just copies but i cant change a layer to it

@ivan.galik Are you using Worksession to attach files?

right click in layer space → attach. i did not use workession (.rws) just ad hoc attachment

That is an alternative method of using Worksession. You are using Worksession. After right clicking, selecting the file to attaching and enter you should see in command history something like:

Worksession: Reading file E:\Downloads E\cesta_model.3dm as an inactive model.

An .rws file is only created when a Worksession is saved. Worksession can be started without involving an .rws file.

Worksession command will open a panel listing the active file and other attached files. Select the file to be detached and click on the Detach button to detach it.

Alternative method to detach non-active file. In the layers panel right click on the “layer” with the name of the non-active file to be detached. A menu should appear with “Worksession Reference” as the first line. Move the mouse cursor over “Worksession Reference” and another menu should appear. Click on “Detach” to detach the file.

This may be a bug. I’ll start another thread to report it. In the meantime workaround is:

Select the mesh faces to be extracted
Complete the command

Select the extracted mesh faces
InPlace option
Complete the command

A copy of the extracted mesh faces will now be in the current layer.

I think so, normal behaviour would be that all commands running on an attached model should create new objects on current layer in current model. I have worked like that many times before and there was no problem.

Agree. I’m working on a new thread to report the bug.

Hi David - that’s fine I can do it from here.


Did you see my thread with a simple example.

I’ve had a similar minor experience. I think the root cause or the issue is that the source layer of the math data you are trying to carry over from the attached file may be the same as a layer name in the active file. I have not had a chance to validate this yet. I’ll send a n update to @pascal if it occurs again in the new subject thread he’s creating.

RH-56390 is fixed in Rhino 7 Service Release 16