Can't delete strange (phantom?) objects in technical view


#1

Hi, I’ve some strange objects appearing only in Technical view. What is even stranger, when I open another file and switch back, the objects disappear, but when I save and reopen the file again, the objects are back. See the video below. I have tried unlock, purge, RefreshShades, nothing worked. Any tips?

Details:
Rhino 5.3.2
Macbook Pro late 2007
2.4 GHz
RAM 4GB
OSX El Capitan 10.11.6


(John Brock) #2

I can’t view your video.
Based on your description, I’ll guess you have some “bad objects” that are confusing the render mesh generation causing a “leaking” mesh, which is making the confusion artifacts.

I suspect in a Wireframe display your file looks fine, but has these odd shaded areas in a Shaded display.

Try running SelBadObjects.
My guess is parts of your model will be selected.
Here’s a link for isolating and fixing these bad objects:
https://wiki.mcneel.com/rhino/badobjects

In the future, I’ts better to post your model. They we don’t have to guess so much.


#3

Hi John,
Thnx for the tips. SelBadObjects have I tried, with no luck. It does look ok in wireframe, in shaded mode too, it’s only in technical view that I see those parts.
The model is for commercial use, therefore I don’t like to share it here. But I will try to modify it and post here some part of it where the phantom objects are still present. That I can.
Meanwhile, is there anything else I can do?


(John Brock) #4

We would need enough of your file uploaded to demonstrate the problem.


#5

Here it is. File with the phantom objects present.
KB_v1.2_copy.3dm (3.7 MB)

Also, here is a file that I link to (embedded and linked) from the main design. I kind of suspect that the phantom objects appeared after inserting this very file. Don’t know if I’m correct though.
wheel front.3dm (4.4 MB)


(John Brock) #6

Can you also please post a screenshot that clearly shows the Technical display mode artifact you’re describing?


#7

Please see the screenshot below.

Here are the steps to reproduce the problem:

  1. open new file
  2. switch to technical view
  3. insert the file “wheel front.3dm” that I sent earlier
  4. select everything and move cca 30 cm away any chosen direction
  5. Phantom objects appear on the place where the wheel was inserted

#8

@John_Brock, thanx for your previous replies. Do you still have any suggestions on how I
can fix the issue?

Regards,

Jan


(John Brock) #14

@Jan_Bashaijha_Mwesig
Thanks for the details.
Yes I can duplicate the problem.

https://mcneel.myjetbrains.com/youtrack/issue/MR-3109