Can't change custom component's class number while using Grasshopper

Hello, I just found that my custom component’s class number doesn’t change well…

that “standard” attribute file have 99 class number, but with grasshopper, it only create components with class number 0.

(this seems the attribute file has 99 class number in it, but grasshopper creates this 0 (black color).

How can i fix this?

thus, this component made by C Sharp script with Tekla API.

Hi Hoeun,

This can sometimes happen when there are multiple Component components in the definition being solved simultaneously. Somehow the Tekla Structures API gets overwhelmed and can ignore the class altogether for some of the inserted connections.

From your pic alone I’m not sure if that’s the case here, or if there’s something else going on.

If you re-trigger the component (e.g. double-click the component name), do the class get fixed?

One option is to turn off ‘Run in background’ for all the Component components (right click the component name > untick ‘Run in background’), that should fix things. You will need to do this for every Component component in the definition.



Hello, Sebastian !
Thanks for the reply.

I tried as you said but turning off ‘Run in background’ for each component doesn’t solve this problem.
Maybe grasshopper can’t support scripted component as well.

I’m afraid that i have to find the other way.
Thanks again :smiley:

Hi Hoeun,

Since that didn’t resolve anything I’d be happy to take a look if you’re able to share the definition with everything internalized. Feel free to send a PM if it’s sensitive!



Thanks for your kindness.

Well, it’s okay but the tekla component i using is just products for sale…

All i did was just make a simple component between columns and beams with this product.

Obviously, If you don’t mind, you can use it with free trials… but i think you maybe don’t have time to seeing so deeply.

you know, this can be kinda… annoying job for you. :sob: