Cannot resize materials

Hi. I’m working with Rhino 6 for Windows and using Thea for Rhino as my rendering engine. I’m new to rendering in rhino. No matter what I do, I cannot change the size or rotate the materials I have applied to my model. I’ve attached some screenshots. I selected the object with the material applied, select “apply box mapping” or “apply planar mapping,” I selected the options in the command line, but when I try to change values in the XYZ size or XYZ rotation boxes nothing happens. What could be going wrong?

For example if you are in box mapping mode, than you can use XYZ rotations to rotate the widget. Or you use the last parameter W of UVW rotation to rotate the texture. W rotation of UVW works for “surface” mapping too. The scale can be edit by XYZ size of the widget or the UVW repeat of the texture.

If you want to see the mapping widget during your manipulations, than use this button before:
image

Don’t forget the mapping method for your textures as well. Making UV mapping changes won’t be of any use if your texture is set to WCS or WCS (Box)’

Thank you for your response. I’m still not able to use either XYZ or UVW. Neither will actually change the mapping of the texture. I’m getting the message "Some of the assigned materials are using ‘WCS’ or “WCS (box-style)’ textures and may not be affected by the values in the dialogue below.” Do you think this could be the source of my problems? I’m new at this. Is there a way to change textures that are WCS so that they work with XYZ or UVW rotations? Or do I need to pick better materials?

Thanks for helping! I think you’re on to something. But I’m not really sure how this stuff works. How do I reset my texture so that it’s not WCS?

When you have your material in the material editor scroll down to where you can see the texture slots. Click on a texture to drill into its settings.

Omg! That solves it. Cannot thank you enoungh. Sending good internet karma your way :slight_smile:

Hello,
I have the exact same problem on Rhino 6 Mac, I’m in the material editor but I can’t see the Mapping Channel / WCS section. Do you have any where it is on mac? Thanks a lot if you can help, I’ve been trying to look for it for a bit now…

I see it on mac, just make sure you are looking at a texture, and not the material (and it is possible that the option does not appear in every kind of texture – for instance, textures that operate on other textures).

Amazing thank you it’s working, I didn’t see at first that I could click on the “color texture link”. Thanks a lot!