C# Visual Studio Community 2019 Rhino 7 Template problem?


It’s been a while since I’ve had to generate a new C# Rhino project from scratch but I’ve encountered a problem creating a new project.

After installing a fresh copy of Visual Studio Community 2019 and after having installed the RhinoCommon and Grasshopper templates from [ here ] when I open visual studio I can create a new Rhino 7 project via the template but the template only seems to create one file (a single rhino command file) rather than a project solution.

The behavior seems to persist regardless of the options selected when using the template.

I’m including 4 screen snaps of the problem.

What have I missed? Does vs 2019 not work for c# rhino projects?

Have you tried running VS in admin mode and/or creating the project in a different folder that is not in desktop and you have complete permissions of?

Seems like the project can be created but it is failed to be saved in your drive. At least this is what I can tell from the star symbol on the open tab, it indicates an unsaved file.

Thanks for the suggestion.

I am the admin user and have never had this issue before. The directories are available as per normal but I appreciate the suggestion. Instead of messing around I just decided to move on and use vs22 which solved the problem.

I do have another problem though - my new project won’t debug with hot reload, to be clear hot reload works with a previous project but not the new project with the new template.

I will search on the forum to see if others have had this problem and submit a new topic if I can’t find anything.

This is a followup on the hot reload error.

I do not know if this was an artifact in a previous rhino c# developer template or a setting that I had introduced by mistake into a project however if anyone ends up with a hot reload error this might help you.

If your project file .csproj contains

  <PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Debug|AnyCPU'">
  <PropertyGroup Condition="'$(Configuration)|$(Platform)'=='Release|AnyCPU'">

You may find that hot reload will not perform correctly. Make a backup of your project and then remove thees two lines of code from your working project and compile.

Hot reload should work correctly.