Build 499 - Keyboard Command Entry


#1

I’m a big user of the keyboard for command entry and the new build seems very clunky when entering keyboard commands or coordinates or values such as a radius for a circle being drawn. For instance to draw a circle I’ll type ci(enter), pick my origin and then type the radius and hit enter. For values of a single digit i.e. 1-9. No problem. When I am entering anything requiring 2 digits or more it seems to randomly take the first digit entry and then just form the circle / confirm an offset distance / whatever. For instance to do a 50mm radius circle I go ci(enter),pick origin,type 5, when I type 0 it seems to take the keystroke for the 0 as an “enter” command and forms a R5mm circle. I say randomly as sometimes if I am slower entering the 5 then the 0 (for instance) it works OK and forms a 50mm circle when I hit enter.
I have no problem when I deliberately go to the new dialog box, click in the values entry box with the cursor and then enter the values, but this is extra steps I should not have to take and very frustrating when forming a lot of circles / offsetting lines / entering coordinates for an origin of differing values constantly when doing the type of work that I do with Rhino and is something that I did not have to do, prior to this build


(Brian James) #2

Hi Simon,

I’ve a guess at what’s causing this issue for you… are you using a Wacom tablet? I believe the slight mouse movement while typing is causing Rhino to use the first number as the radius and not waiting for you to press enter.


(Marlin Prowell) #3

Please try the 2014-02-03 WIP release to see if it fixes this problem.


#4

Hi Brian
No I don’t use tablet, but thinking about it and reading a couple of other posts the way I use my mouse may be acting the same way, as I hold my mouse in my right hand while keying in commands with my left before hitting enter with my right hand or co-ordinates with both hands so am probably moving the mouse slightly when I let it go. Would explain the randomness ??
Never the less have just downloaded build 501 so be interesting to see if I am seeing the same thing as the developments and changes information on the download mentions a cure for the cursor movement confirming the entry.
Thanks


#5

Hello!
I’m having a similarish problem (build 501). Making a rectangle I

  1. choose rectangle tool
  2. enter “0” for origin
  3. now say i want to make a 200 by 200 mm rectangle; when I hit the first “2” it switches my cplane to “world front”.

There’s no alias assigned in preferences for this action, but “2” seems to be a hotkey for that action…

In any case I I think hotkeys should probably be deactivated when any tool is active, right?

-Stefan


#6

Fixed. My bad.